Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

DirectX + NVida MX 440 Problems

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
Hello everyone,

I am new to this forum, and want to thank everyone in advance who replies with helpful responses. I am running a 2.53 GHZ Custom Built Machine, on 512MB of ram. My graphics card is a NVida MX 440, (yeah I know it is cheap, but it works good to me, or was before upgrading to XP Professional).

I wanted to play Ragnarok Online, so I downloaded the client, ran the patch client, then when it was done patching, I clicked 'Start Game'. It displayed an error 'Cannot init d3d or grf files are corrupt'. I had this problem before with RO on a 800MHZ HP Machine with on-board graphics controller by IBM. Normally I just had to restart the machine or adjust the display settings. So I did this, and to my luck still nothing. When I goto settings to check what device RO is using, it shows up blank, so I researched that too and came up with checking to make sure that my graphic cards drivers are up-to-date as well as Direct X.

So from there, I downloaded updated drivers for my NVida Card, Downloaded DirectX 9.0C, & ran Windows Update to make sure there is no updates I am missing. Still to my luck, I ran into the same problem. So this time I ran DirectX Diagnostic Program, and all the tests passed, tho I did notice something weird, DirectDraw said "Not Available" tho ... My card supports DirectDraw as it was enabled before I upgraded to Windows XP Profession when I was on Windows 2000.

Another weird thing I notice is when I ran the DirectDraw Test, it passed, tho that was not the weirdest part, but at the top when it shows the Approx. Total Memory on card, it shows n/a and VDD say's n/a.... I don't know what is wrong.

I ran into a dead-end, I have tried everything I could thing, including:

* Downgrading to DirectX 8.1
* Rolling back my graphic's driver
* Reinstalling DirectX 9c
* Uninstalling RO
* Reinstalling RO

Also, I noticed when I go to install DirectX 9c now, it asks me to accept the License Agreement which I do, then I press next, and it instantly says 'all the files are finished updating'., I reboot and it shows 8.1 still as the version for DirectX, so it is like DirectX is not even being installed when I do that.

I hope someone can help me out, please reply to this post if you have any helpful tips!

Thanks a bunch in advanced!
Keitaro Urashima
  • 0




    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts

I ran the DXDiag.exe Tool again, here is the log file.

Attached Files

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP