Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Pinnacle Studio 8 AV/DV card not working

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 7 posts
I installed the AV/DV card that comes with Pinnacle Studio 8 and after I place in the PCI slot, I install the software on the disks and then reboot when asked. Upon restarting, the computer then detects the new hardware again and asks for me to locate the drivers. I go into hardware manager and see that the only part of the card without drivers is the 1394 port, the only part that I need! The computer also says something about a PCI to PCI bridge when it detects the card for the second time. I've been to the Pinnacle website, but none of the drivers there work. My computer runs Win XP with a AMD 64 bit 3200 processor and 1.2 Gigs of RAM. Thanks.

Here are pics of what I'm talking about


  • 0




    motto - Just get-er-done

  • Technician
  • 4,345 posts
This probably doesn't help but i bought Pinnacle 9 and found it so buggy and the card wouldn't work that i ended up getting rid of all of it. I hate it when people put out bad software and bad drivers for their cards.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP