Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem with External Hard Drive


  • Please log in to reply

#1
Airbarto1

Airbarto1

    Member

  • Member
  • PipPip
  • 71 posts
Hey - I had a computer problem in the past that you guys were really great with helping me so I'm back with another...

I've had an external hard drive (iomega) that connects through my USB port for about a year now and up until about a month ago it was always designated as my E Drive. However about a month ago while I was charging my ipod in my other usb port I put the external disk drive usb plug back in and it all of a sudden designated the drive as my F Drive, with the Ipod now being the E drive. There are several devices I use through my USB ports, photo transfer tool, ipod charger, mouse, and the hard drive, but this was the first time the hard drive was referred to as anything else but the E drive. The problem with this is that on my hard drive is my entire music library (thousands of songs), and now itunes, and other music players, will not play my music because it can not find it - as it is looking in E:// and not F://. I know I can just reimport the songs but I dont' know if at some point in the future the hard drive won't suddenly be designated as the E drive again.

So is there any way I can tell my computer what drive I want my hard drive to serve as? Like if it is currently referred to as the F Drive is there some way I can override that and make it my E Drive?

Thanks so much - hopefully there is a simple way to solve this problem...
  • 0

Advertisements


#2
SRX660

SRX660

    motto - Just get-er-done

  • Technician
  • 4,345 posts
I think if you plug the external drive in before any other usb devices XP will see it as the "E" drive. You may need to unplug the ipod stand if you leave it connected to the computer. Also, if you unplug the external drive and have other hardware plugged into the usb XP will always choose the next letter past what usb devices plugged in when you plug the drive in.

SRX660
  • 0

#3
Airbarto1

Airbarto1

    Member

  • Topic Starter
  • Member
  • PipPip
  • 71 posts
I've actually tried that and that doesn't work. I've tried a whole combination of unplugging and replugging certain devices in combination with the hard drive but it still refers to it as the F drive. I've unplugged everything, then restarted the computer and plugged in the hard drive but still it comes up as F. The most annoying thing is I usually never plug my ipod into the computer to charge it, usually I only plug it in to transfer music onto it, in which case the external drive is already attached, however I am currently a college student studying abroad so it is easier to charge my ipod through my computer than to use and adapter and plug it into the wall. I mean I know I can probably just delete everything from my itunes and then reimport the music from the F drive, but that deletes all my playlists and is will be a long ordeal - there has to be a way to get my computer to name my hard drive E://. If you have any other suggestions that'd be great - i don't know why my computer just won't automatically refer to it as E.



thanks

anthony
  • 0

#4
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,575 posts
You can select the drive letters from the disk management tool:

Go to Control Panel -> Administrative Tools -> Computer Management. In there go
to Disk Management.

Right click on the device and one of the options should be to change the drive letter.

You can change the ipod to be another letter and set the disk to e: I prefer to set the drives so that things don't change, like setting the CDROM/DVD to X and Y.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP