Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

VPN with XP pro


  • Please log in to reply

#1
garf12

garf12

    Member

  • Member
  • PipPip
  • 15 posts
Is it possible to set up a VPN server in xp pro? I have been searching around and cant find much about it. I have never messed with a VPN before so its all new to me. If its not possible is there some 3rd party software that will do it, I would rather not have to buy windows server.

thanks
  • 0

Advertisements


#2
coachwife6

coachwife6

    SuperStar

  • Retired Staff
  • 11,413 posts
I have a VPN and I'm using XP Pro.
  • 0

#3
chicagotech

chicagotech

    Member

  • Member
  • PipPipPip
  • 197 posts
quoted from http://howtonetworki...om/vpnsetup.htm

How to configure Win 2000/XP Pro as VPN host
Prior to Windows 2000/XP Pro, you must add PPTP on NT 4.0 Server to establish VPN connections. With the release of Windows 2000/XP Pro, you have the ability to run a Windows 2000/XP Pro as a VPN host. However, Windows 2000/XP Pro enables only one VPN connection at a time and requires Internet Protocol (IP).

Before you start the VPN configuration, you should have a equipment (modem, T1, Frame Relay, ADSL, or cable modem) connecting to the Internet. Also make sure you have correct TCP/IP settings on the W2K/XP.

To setup Win XP (in our case) Pro as VPN host, go to the Properties of My Network Places>Create a New Connections>Set up a Advanced Connection>Accept Incoming Connections. On the Devices for Incoming Connections dialog box, do not select any device, only click Next and check Allow Private Connections, and then click Next. On the Allowed Users dialog box, select or add all users for whom you want to enable access. The accounts have to exist on both computers that are involved in establishing the VPN connection. On the New Connection Wizard, File and Printer Sharing for Microsoft Networks, Internet Protocol (TCP/IP) and Client for Microsoft Networks should be listed as networking components. By default, Allow callers to access my local area network and Assign TCP/IP address automatically using DHCP are checked. If you would like to keep the default settings, click Next to continue. Now, the Incoming Connection icon should show on Incoming section under the Properties of My Network Places and is ready to use.
  • 0

#4
garf12

garf12

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Wow that was easy thanks!
  • 0

#5
garf12

garf12

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Ok I can connect fine as long as I am in the LAN, but when I try to connect from the outside I am having problems with the router firewall. My router doesnt have the VPN setup option, so I am just having to do port fowarding.
I read the guide on howtonetworking.com and it says.

A: PPTP VPN uses TCP Port 1723, IP Protocol 47 (GRE); L2TP: UDP Port 1701; IPSec: UDP Port 500, Pass  IP protocol 50 and 51. Note: 47 is a protocol number and not TCP port. The protocol name is GRE. It'll make a big difference when configuring your firewall or router.


So I fowarded 1701 500 50 51, but I dont understand what it means by 47 is a protocol number and not a TCP port. How do I put that into the fowarding menu? Its getting close because it connects and all but when it gets to verifying username and password it takes about 30 seconds then says "Error 721: The remote computer did not respond. For further assistance......."

any ideas?

thanks!
  • 0

#6
computerg33k

computerg33k

    New Member

  • Member
  • Pip
  • 1 posts
I'm also havingn this same problem--have you found an answer?
  • 0

#7
garf12

garf12

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
nope I called linksys and they told me a few ports to foward but still having problems connecting. I know its all set up right cause it will connect right it just wont authenticate. So I am guessing that I dont have the port open that is used to authenticate.
  • 0

#8
natcom

natcom

    New Member

  • Member
  • Pip
  • 2 posts

nope I called linksys and they told me a few ports to foward but still having problems connecting.  I know its all set up right cause it will connect right it just wont authenticate.  So I am guessing that I dont have the port open that is used to authenticate.

View Post



Hi guys i think i have the answer you guys are looking for read here

http://support.micro...kb;en-us;271731
  • 0

#9
natcom

natcom

    New Member

  • Member
  • Pip
  • 2 posts

Hi guys i think i have the answer you guys are looking for read here  doing the
registry change fix that problem for some people

http://support.micro...kb;en-us;271731

View Post


  • 0

#10
chicagotech

chicagotech

    Member

  • Member
  • PipPipPip
  • 197 posts
in many case, enable PPTP will open GRE ip protocol 47 automatically. or the router pptp pass-through is ready fo GRE,
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP