Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

two problems


  • Please log in to reply

#1
steelydan

steelydan

    Member

  • Member
  • PipPip
  • 23 posts
hello

problem one
when starting windows it asks which os to start with winxp or microsoft windows
ive looked around in the forums and found system/advanced/startup and know i need to delete one of the below

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\ = "Microsoft Windows"

if you could show me which parts of above i need to delete and save i would appreciate it


problem two
part a:how do i convert my c: drive from fat to ntfs?

part b:everytime i start windows it wants to run checkdisk on my 2nd hard drive e:, even if i let it run through the check and win finds it is ok it will want to check everytime at startup

thanks in advance for any help

-s
  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi steelydan...

Problem 1
Look in the C: Drive...do you have more than one Windows folder? Your boot.ini shows only one installation...don't change it. Perhaps we just need to set the Default System settings.

Problem 2a
Click Start, then Run, type cmd, and click "Ok". At the command prompt, type Convert C: /FS:NTFS, and press "Enter". This is not supposed to effect your data, but I'd back up any important files anyway...better safe than sorry.

Problem 2b
This one may be a bit more involved. Let's check for a Dirty Bit, first. Click Start, then Run, type cmd, and click "Ok". At the command prompt, type fsutil dirty query e: ..... (This queries the drive and will tell you if it is dirty). Let me know what you find here so we know how to proceed.

wannabe1

Edited by wannabe1, 27 March 2006 - 01:51 AM.

  • 0

#3
steelydan

steelydan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
hello wannabe1

many thanks for your reply to my post

problem 1
as far as i can tell there is only one windows folder....

problem 2a
the conversion to ntfs went very well, this was a fresh install and i had nothing to backup so i went ahead w/ the conversion.

problem 2b
the fsutil dirty query to e: came bas as dirty

thats one down, again thanks for your help

-s
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hello steelydan...

Problem 1
Open Computer Management...Right click on "My Computer" and choose "Manage". In the console tree, right-click "Computer Management (Local)", and then select "Properties". On the "Advanced" tab, under "Startup and Recovery", click "Settings".

In the "Default Operating System" dropdown menu, choose the OS you wish to start when you boot. Deselect the checkbox next to "Time to display list of operating systems". Click on the "Edit" button. Click on "File" on the toolbar and select "Save As" and save a copy of the boot.ini (name it boot.old) to your desktop. Then remove (Delete) the text shown in red below. Click "File" and select "Save". Click "Ok", "Apply", then "Ok". Close the management window. Reboot. If all goes well, you can delete boot.old from the desktop.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\ = "Microsoft Windows"

__________________________

Problem 2b
We need to unset that Dirty Bit.
  • If you have Spyware Doctor installed, uninstall it.
  • If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.
Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one: (Please note the spaces in the following commands.)
  • chkntfs /d ..... (This will reset autocheck options to default)
  • chkntfs /c E: ..... (This will allow checking drive E:)
  • fsutil dirty query e: ..... (This queries the drive and will most likely tell you that it is dirty)
  • chkntfs /x e: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

This next step is important as this is where the Dirty Bit will be unset.
Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)
  • chkdsk /f /r e: ..... (To manually run a full chkdsk operation)
  • Y ..... (To accept having it run on the next boot)
This should take you through 5 stages of the scan and will unset that Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type fsutil dirty query e:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Now reboot again and see if chkdsk still runs on bootup.

wannabe1

Edited by wannabe1, 27 March 2006 - 08:19 AM.

  • 0

#5
steelydan

steelydan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
wannabe1

all fixes worked very well

one quick question where does the boot.ini file usually live since modification it is now sitting all exposed when i open c: could i possibly tuck it away somewhere....perhaps inside of windows?

thanks for all your help

problems resolved

you rock

-s
  • 0

#6
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
steelydan...

Is the boot.ini file residing on the C: drive the old one or the edited one? You shouldn't even be able to find the boot.ini...let alone have it just sitting in the open. Open it with notepad...If it contains C:\ = "Microsoft Windows", it can be safely deleted or moved to another folder.

Glad we got you all fixed up!! :whistling:

wannabe1
  • 0

#7
steelydan

steelydan

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
sorted the boot.ini it was indeed my old one, which i forgot to rename

thanks again

-s
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP