Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Help With New Build ASAP


  • Please log in to reply

#1
Jlholmes

Jlholmes

    New Member

  • Member
  • Pip
  • 1 posts
Yo, heres the scoop. I just built my third computer and sumthin is fishy....heres my system info before I explain my prob...

ASUS A8V ATX AMD Mobo
Radeon Powercolor 9800xt
1 gig Kingston Ram
3- 80 gig HD
450 watt PS
AMD 3700 San Diago 64 bit Processor/Stock Fan


Heres my problem, when I boot and the computer is posting, all the words are choppy and the picture looks like [bleep].....My first thought was my video card, but its practically brand new, and not a cheap one. So its not like i can just buy a new one because I think thats the problem....and thoughts????? Lemme know...
  • 0

Advertisements


#2
SuperSam

SuperSam

    Member

  • Member
  • PipPipPip
  • 693 posts
My 9800XT was faulty, but I accidentally spilt water on it from my water cooling :\. Maybe try to ask for another, or try another video card in it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP