Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

No default gateway


  • Please log in to reply

#1
wombo

wombo

    Member

  • Member
  • PipPip
  • 15 posts
Hi, I've just encountered a problem today with my internet. I'm going through a router (DI-604) using windows xp. Appearently, I have no default gateway when i run cmd and type in ipconfig. I've tried iprelease, iprenew, winsockxpfix, system restoring, uninstalling the hardware and rebooting..and possibly almost all solutions posted in different forums. It happened this morning, and after reading one of the earlier posts (http://www.geekstogo...ess-t41075.html), Joanna mentioned about "forcing" the computer. i kind of did that today. I usually leave my computer on sleep or turn it off but it kinda "froze" up today when i turned it to sleep mode...it did eventually but when i turned my computer back on, it again froze and nothing showed up, so i restarted my computer. Next thing i know, there's no connection to the internet. also, the second pc in my house works perfectly fine (thats how im posting this) but mine seems to be kind of in a mess

right now my ip address is in the 169.254 range...i know its something about windows assigning that if there's no dhcp server...appearently when i try to repair my connection, it says unable to renew ip..and same thing goes when i try ipconfig /renew...it times out

anyways i hope thats specific enough



edit: sorry...just realized its in the wrong section..can a mod please move it to the correct section?

thanks, wombs

Edited by wombo, 02 April 2006 - 09:36 AM.

  • 0

Advertisements


#2
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts
First of all, power cycle the modem,router and the system for about 5 mins. Turn on the system and check if that helps. If it doesn't, check the DHCP settings [for more info - check this]

Did you reinstall tcp/ip after you delete the winsock keys?

Also, you can deactivate the Auto IP generation for the system from the registry -

Start > Run > regedit

Browse to -

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Add the following value to this key:

"IPAutoconfigurationEnabled", Value type: REG_DWORD Value in hexadecimal: 0
  • 0

#3
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts

Did you reinstall tcp/ip after you delete the winsock keys?



I actually deleted the tcp/ip in the device manager and then restarted my computer, then used winsockxpfix...am i supposed to delete and then use winsock?

right now i just replaced my winsock and winsock2 registrys and restarting my computer...keep on trying the list you posted and keep you updated, thanks for your reply

wombs
  • 0

#4
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts
'netime :whistling:

Try this for winsock -

Start > Run > regedit

Registry Editor -

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

Export, Save and Delete - 'Winsock' and 'Winsock2'

Restart the system.

To reset Winsock and TCP/IP settings, perform the following steps:

Start > Run > ncpa.cpl

The Network Connection -

Right-click > Local Area Connection - Properties.

General tab > Install.

'Select Network Component Type' -

Protocol > Add.

'Select Network Protocol'-

> Have Disk

'Install From Disk'

Type 'C:\Windows\INF' > OK

Click Internet Protocol (TCP/IP) > OK.

The Network Connection Properties window appears.

Close

Restart the system.

  • 0

#5
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
hey, i've just restarted my computer after taking those steps...just a quick question

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

you said to:

Add the following value to this key:

"IPAutoconfigurationEnabled", Value type: REG_DWORD Value in hexadecimal: 0

do i create a new key?

edit: i've just added the key and restarted the computer
ive also tried the installation for winsock, at first i have no ip (0.0.0.0) but it changes back to 169.254 after a couple of minutes

wombs

Edited by wombo, 02 April 2006 - 10:34 AM.

  • 0

#6
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts

"IPAutoconfigurationEnabled", Value type: REG_DWORD Value in hexadecimal: 0

do i create a new key?


No, when you browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters, look at the right-hand pane for IPAutoconfigurationEnabled, and change the value to 0 to turn it off.
  • 0

#7
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
I've removed the key i added.

anyways, there's no IPAutoconfigurationEnabled, but there are
IPAutoconfigurationAddress - 169.254.89.145
IPAutoconfigurationMask- 255.255.0.0
IPAutoconfigurationSeed - 0
IPAddress - 0.0.0.0
IPEnableRouter - 0

Does this help at all?


also i'm not receiving or seding any packets but my cables seem to be working fine

Edited by wombo, 02 April 2006 - 10:43 AM.

  • 0

#8
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts
Okhay.. dat's fine. Can you please check the IP address in safe mode with networking? [F8 on startup]. It might also be some antivirus/firewall or any 3rd party software blocking the connection.
  • 0

#9
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
The ip is still 169.254.xx.xxx
  • 0

#10
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts
Can you try running sfc /scannow ? [ Start > Run > sfc /scannow (you might need XP CD for this)]

Also, can you try connecting the modem directly to the ethernet adapter instead of going through the router and check out?
  • 0

#11
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
I've already tried a direct connection with my modem, but that didn't work. I'm half way through the scan and I'll repost when I'm done with it.
  • 0

#12
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Seem's i've got my default gateway

Network Connections > Properties > TCP/IP > Properties > Alternate Configuration and i manually put in the ip, mask and gateway..but still no packets sent or received


edit: i've removed the manual ip since it seems it wont help at all...i've completed the scan but nothing happened afterwards

Edited by wombo, 02 April 2006 - 11:20 AM.

  • 0

#13
Zoey Z

Zoey Z

    Member

  • Member
  • PipPip
  • 15 posts
Hi again wombo, how's it going? What kind of n/w adapter do you have? Try uninstalling the driver, and then the h/w from device manager, and reboot. Then install the driver back from the CD (or try an updated driver if there's one available).
  • 0

#14
wombo

wombo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
Hey Zoey, I've just realized that night that the LAN light at the back of my CPU wasn't on. I've tried reinstalling and rebooting and reinstalling the driver again, but that didn't work. I decided to format my computer and that didn't solve the problem either, so I switched to my network adapter and connecting via USB. I'm not sure but I believe there's something wrong my with ethernet card or whatever at the back, anyways thanks for the helps, really appreciate it.

Wombs
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP