Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Primary Drive Problem

  • Please log in to reply




  • Member
  • PipPip
  • 43 posts
I have 3 hard drives in my computer one is an SATA which has an installation of windows XP on it then there are two are IDE dives. I installed a version of windows 2000 on one of the ide drves today and every thing worked fine but for some reason when i boot windows 2000 It labled the intallation Drive with windows as "D" and the other ide drive(which i need to keep free from any system files) was labled as "C"

i went to computer managment and it says that the "C" drive is Disk 0 (system) and the "D" is Disk 1 (boot).
why did this happen? I wanted to install 2000 as if that other drive did not exist. is there any way i can set the drive that has the 2000 installation on it to be the primary so it will function fine with out the other drive?

i was also woundering if there any setting i can apply, so that when people install programs on this comp it will not give them the default destination as C:\ but instead will make them install it to D:\ beacuse i try to explain this to people and they dont listen and i cant afford to have people installing stuff on "C" This would be usefull in many other areas for me if thats possible as well. Thanks very much for any and all the help you can give me.
  • 0





  • Member
  • PipPipPip
  • 495 posts
Ok, a few things here. First off, if the SATA drive contains your primary OS, that means you set it to SATA port 0. Which is just fine. What you don't realize is that ( unless I'm mistaken ) Sata port 0 takes precedence over IDE 1 master.

I assume you've used microsoft's bootloader toswitch between Windows installations, but traditionally microsoft says its too complicated to install windows on another than the primary drive. Hats off to you, you did a good job till now, its actually going exactly as it should.

When you came to install win 2000, it saw the drive as D:, because windows XP designated it as D: Win2000 must have detected the windows XP, and knows better than to fiddle with the drive letters like this. XP needs the C:, so 2000 used D:

As for changing the programs drive, that one is easy.

go into the registry, please. It's important to remember that the registry is quite possibly the most sensitive area of your Windows. Never delete any keys unless you've exported them first. Never change anything unless you're asked to by one of us. We have experience with the registry, you may not have any, or very little.

start menu/run/ regedit


Now, in the right pane, locate the following key


This setting is usually associated with C:\Program Files

Change it to D:\, like so

ProgramFilesDir D:\

That's what you should see in the window now.

If you want to use D:\Program Files, type it in. Just copy and paste the directory you wish to have it use.

All this is done from within your windows 2000 by the way. After it's done, reboot, and test an installation. It should be using D:\ ( or D:\Program Files ) now.

Good luck
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP