Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

External harddrive changed from F to G for no reason


  • Please log in to reply

#1
cafrank

cafrank

    New Member

  • Member
  • Pip
  • 2 posts
The external harddrive (the only external device connected), has always been designated F: drive. For some unknown reason it has changed to G: I have C:, D: and E: drives internally but no F: now since my external F: drive was mysteriously designated G: How can I get it to again be designated as the F: drive.

I tried unplugging the external drive, then plugging it into other USB2 ports, rebooting etc. to no avail.
If I plug in a thumb drive, it is recognized as the F: drive (previously it was always the G: drive). It seems that the external drive is telling my computer to recognize it as the G: drive??
  • 0

Advertisements


#2
Spike

Spike

    nOoB

  • Member
  • PipPipPipPip
  • 1,351 posts
Hey there cafrank, welcome To Geeks To Go Forums.

I am not to sure on the reason of the change but.... Maybe you loaded a program (Eg. CloneCD) which makes its own virtual drive (In this case F:\ when the external was unpluged) and then you had uninstalled it. This is just my guess, if you never loaded any programs I am not to sure what could of caused this but I can try give you the solution.

Once the external Hard drive had been pluged in and has been recognised by windows as "G:\" then goto:
> Start
> Control Panel (In Classic Start Menu, >Settings >Control Panel)
> Administative Tools (You may have to change to Classic View [You can find this on the left hand side of control panel, there is a menu bar])
> Computer Management
> Stroage (Once inside computer management)
> Disk Management (Expand Storage)

You will then see a list of drives, select your external (G:\) right click and click "Change Drive Letters and Paths..." from there it should be easy for you to understand but if you have any other questions or need help in the proccess let me know.

Thinking of it now, the other reason for the drive to have changed its letter is windows may have reserved the drive letter for another removable item(Eg. Memory Stick)

Cool, let me know if this all worked. :whistling:
  • 0

#3
cafrank

cafrank

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thanks so much for the great help spike_hacker. Problem fixed. I am very grateful
  • 0

#4
Vaillant

Vaillant

    Member

  • Member
  • PipPipPip
  • 495 posts
Do you have Sygate Firewall installed?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP