Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot connect to FTP


  • Please log in to reply

#1
Nick052

Nick052

    Member

  • Member
  • PipPip
  • 28 posts
Hi,

I am having major probs connecting to ftp://ftp.btopenworld.com on Windows XP.

If I do this on a Win 98 machine I have access to, it comes on immediately and works totally fine.

On XP, I just get
"Windows cannot access this folder. Make sure you typed the file name correctly and that you have permission to access the folder.
Details:
The operation timed out."

And If it try it using LeechFTP I get "No Socket" errors.

I have tried the following:

1. Turning my wireless router firewall off
2. Turning ZoneAlarm off
3. Replacing Zone Alarm with Kerio Firewall then turning that off
4. Turning all "other" firewalls off and using Win XP firewall (with the ftp patch as an exception)
5. Tried ticking and unticking "Use Passive FTP" option in Internet Explorer
6. Used WinSockXPFix to restore settings
7. OPened command prompt, and tried to ftp through here, got: "ftp: connnect :Unknown error number" error.
8. Turing all firewalls off

Nothing works - anyone any ideas?

Driving me mad cos running out of options!!

Im sure that increasing the network timeout will have no affect (dont know how to do it anyway!) since it should come on straight away as on my Win98 machine.

Any help greatly appreciated!
  • 0

Advertisements


#2
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Hi,

I forgot to say that I CAN successfully "Ping" ftp.btopenworld.com from a command prompt.

Cheers,

Nick.
  • 0

#3
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
http://support.micro...om/?kbid=323446


also try using this method - use the below url (obviously modify it to include your username and password) to get to the ftp site

ftp://username:password@ftp.btopenworld.com
  • 0

#4
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Thanks:

I now no longer get any error message in Windows XP, I just get the standard "Page Cannot be Displayed" page after waiting ages.

So I may be a step nearer - anyone any further ideas?

CHeers.

Edited by Nick052, 07 April 2006 - 01:23 PM.

  • 0

#5
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
There were a number of changes to ie in service pack 2 that make it difficult to use it as an ftp client, though I am perplexed as to why Leechftp does not work

I would scrap IE all together and focus on Leechftp

try this

1. Click Start, click Run, type wscui.cpl in the Open box, and then click OK.

2. Click Windows Firewall.

3. In the Windows Firewall dialog box, click the Exceptions tab, and then click Add Program.

4. In the Add a Program dialog box, either select the program from the list that appears, or click Browse to locate your program.

If you cannot locate your program, see the next section.

5. After you select your program, click OK.

6. On the Exceptions tab, make sure that the check box next to your program is selected, and then click OK.
  • 0

#6
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Hi, thanks for reply.

I have tried the above, but didnt work.

Still get the Socket Error: no connection.

This is my current configuration:

1. Firewall on my wireless router ENABLED
2. Kerio Personal firewall on my PC ENABLED
3. Windows Firewall DISABED

However, I have tried disabling ALL firewalls (inc router and XP one), but still get "Socket Error: No connection"

Anyone any other ideas?
  • 0

#7
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
where are you connecting from? Home? Work?

Is there a proxy server in this mix somewhere?
  • 0

#8
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Im connecting from a normal PC on a wireless router network.

I have Kerio Firewall, a wireless router firewall, but even with these off, it still wont connect.
  • 0

#9
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
That does not answer my question

Home...does your ISP use a proxy?

Work...does your workplace use a proxy server. You could be in an office with a wireless connection for the local lan, but a hardwire to the internet. It sounds like home, but I cannot be certain.

Who is your ISP?

Try using filezilla as a client,,,,does the same occur with ftp?

http://filezilla.sourceforge.net/

(awesome ftp client--and free)
  • 0

#10
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Apologies for not being clear.

I am using a home Windows XP home PC on a wireless network and my ISP is www.Plus.Net (PlusNet) - I am not sure if they use a proxy server, which prob means they dont?

I have downloaded FireZilla - I get Error: Unable to Connect whenever I try to connect to ftp.btopenworld.com with my username and password on port 21.
  • 0

Advertisements


#11
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Bit more info for you..

I have discovered I can connect to other ftp sites ok!

E.g. ftp://ftp.westwood.com works fine - I get the FTP root internet explorer page fine.

This would suggest a problem with ftp://ftp.btopenworld.com , but I know I can access this with no problems at all on my Win 98 machine.

Hopefully narrowing down the problem now - any further suggestions?

Thanks for all your help.
  • 0

#12
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
did you switch over to filezilla?

DId you set up a connection. Choose the connection properties, then choose advanced, and set to passive mode.

I assume this is to update your website that you have hosted with btopenworld?

Didn't they get bought out by yahoo?
  • 0

#13
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Hi,

Yes I swtiched to Firezilla.

Have tried the Passive mode and also tried ticking "Bypass proxy settings", but still doesn't work.

Yes, its to update my website thats www.horseraceofyear.btinternet.co.uk

I used to connect to ftp://ftp.btinternet.com using LeechFPT and it worked fine.

After speaking to BT Technical support, they told me this was now fpt://ftp.btopenworld.com, which is true since on a Win98 machine I have access to, I am able to login and upload and download files.

Its just this XP machine thats playing up.

Can you access ftp://ftp.btopenworld.com through Internet Explorer?

It should let you without logging in with a username and password.
  • 0

#14
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
no, I cannot. I get the same errors.


What if you bypass the router? Hooking your PC straight up to the internet
  • 0

#15
Nick052

Nick052

    Member

  • Topic Starter
  • Member
  • PipPip
  • 28 posts
Its interesting how you get the same errors - suggests the address is incorrect.

Can you connect to ftp://ftp.btinternet.com?

I am unfortunately unable to try the direct internet access option since it would involve me transporting my PC some distance and I am not sure I have a cable to do this anyway.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP