Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CheckDisk everytime i boot up my pc.


  • Please log in to reply

#1
doire

doire

    Member

  • Member
  • PipPipPip
  • 210 posts
I went into my computer, right cl;icked on my C drive...properties.....tools.....check now and clicked the two boxes to run checkdisk onm my next reboot.

Now EVERYTIME i reboot the pc says it is checkin the disk. How can i stop this?

Ive never seen this happen before.

Thanks. :whistling:
  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Hi doire...

Click Start, then Run, type cmd, and click "Ok". In the command window that opens, type fsutil dirty query c: at the prompt and press "Enter".

Does the result of this indicate the drive is "Dirty"?

wannabe1
  • 0

#3
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Thanks for the reply. Im at work at the moment and the problem pc is my home pc.

If i try what you said and it indicates its dirty...whats the next step?
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
If the drive has been flagged as "dirty" (this is called a "Dirty Bit")...You'll need to unset that Dirty Bit.
  • If you have Spyware Doctor installed, uninstall it.
  • If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.
Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one: (Please note the spaces in the following commands.)
  • chkntfs /d ..... (This will reset autocheck options to default)
  • chkntfs /c C: ..... (This will allow checking drive C:)
  • fsutil dirty query c: ..... (This queries the drive and will most likely tell you that it is dirty)
  • chkntfs /x c: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

This next step is important as this is where the Dirty Bit will be unset.
Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)
  • chkdsk /f /r c: ..... (To manually run a full chkdsk operation)
  • Y ..... (To accept having it run on the next boot)
This should take you through 5 stages of the scan and will unset that Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type fsutil dirty query c:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Now reboot again and see if chkdsk still runs on bootup.

As an aside...you might go back and see if the boxes you selected to originally run chkdsk are not checked.

wannabe1

Edited by wannabe1, 24 April 2006 - 07:51 AM.

  • 0

#5
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Thanks wannabe1. I will try this once i get home tonight and let you know the results tomorrow. :whistling:
  • 0

#6
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Hi Wanabe1,

Just to let you know that i disabled spy doctor....rebooted and then the pc went through chkdsk.

I rebooted again and the chkdsk screen wasnt there.

It seems that when i scheduled chkdsk to run on reboot, it waqs prevented from doing so by spy doctor.

Disabling spy doctor allowed chkdsk to run and therefore chkdsk didnt try and run after each boot up.

Problem sloved.
  • 0

#7
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
Good news! :whistling:

I'm slowly discovering that Spy Doctor is generating a false positive for the Dirty Bit as you are the second member that has solved the problem by just uninstalling the application... :blink:

Thanks for letting me know!

wannabe1
  • 0

#8
doire

doire

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 210 posts
Opps!

Forgot to say....Thnaks for your help :whistling:
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP