Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

D-Link DI-604


  • Please log in to reply

#1
Thebinaryman

Thebinaryman

    Member

  • Member
  • PipPipPip
  • 326 posts
ok, i have the di-604 router. i would like to have it forward port 80 to one of my computers. so when someone types in my ip adress: 68.114.xxx.xx:80 it will automatically connect to the web server on the computer 192.168.0.101:80 which is the computer in my sig, the web server (apache) is working fine localy. i can type in the local ip on any computer's browser on my network, and get the test page, but out of my house, it does not work. i thought i had port forwarding setup correctly, and it appears as though the firewall is disabled for port 80, i've tried everything tinkering around with it, am i missing something? would it be better if i put two network cards in another computer, and used that (running an os like ipcop) as a router, and then connected that to a switch, then to the rest of the computers? this is sorta a test if i can get a web server working, if i can acomplish this, then ill devote another computer for a web server running 24/7 for me and my friends to store files on.

thanks for any input. tell me if something i said is unclear.
  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Thebinaryman,

I can't really tell you if you've set up Port Forwarding correctly if I don't know what steps you've taken :whistling: Also, your firewall shouldn't be "disabled for port 80", but should rather be forwarding all inbound HTTP traffic to 192.168.0.101. Follow the steps listed here in order to setup Apache; remember that your Private IP is 192.168.0.101 :blink: If you run into any problems / you have already done these steps and I'm posting redundant information, then please post back.

EDIT: And no, it wouldn't be easier to use two NIC's in a "Server computer".

- Dan

Edited by Dan G, 10 May 2006 - 02:57 AM.

  • 0

#3
Thebinaryman

Thebinaryman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 326 posts
here are some screenshots of router config:

Posted ImagePosted ImagePosted ImagePosted Image

i've tried with dmz enabled and disabled. when on the computer itself, or another one in my house, i can type in "192.168.0.101", even typing in my real ip "68.114.xxx.xx" and it will automatically forward like i want, but outside the house it will not.

i will look over my apache setup again like you suggested. and btw. there is no software firewall on the computer, just the simple hardware one built into the router.

thanks

edit: and also i forgot to mention, but i would like to use vnc server/viewer as well. again it works fine inside my house, but outside i cannot connect to remote control any computers. needs to forward from the normal 68.114.xxx.xx (at various ports: 5900, 5901, 5902, 5903...) to 192.168.0.100, 192.168.0.101, 192.168.0.102...

Edited by Thebinaryman, 10 May 2006 - 05:37 PM.

  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Can you please post an update once you re-setup the Apache forwarding; that would be the place to start.. Does it work?
  • 0

#5
Thebinaryman

Thebinaryman

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 326 posts
sorry about my late reply

the only thing that differed from my setup to the setup guide you linked me to is that port 443 was not enabled. i enabled forwarding on that too now. also i had them named differently, i left it called "virtual server http" instead of "apache1" like the guide suggested. nevertheless i changed the name to "apache1" and "apache2" respectively. it is now set up just as the guide calls for.

still not working outside the house. :whistling:

thank you for your help. i guess i must have some picky little thing configured wrong, hopefully i will come across it sometime.

i now have another router in the house, a d-link di-624 currently not being used. if i have time i might try plugging that in, and seeing if i'll have better luck configuring that.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP