Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Safely Remove hardware


  • Please log in to reply

#1
hawthorn

hawthorn

    Member

  • Member
  • PipPipPip
  • 203 posts
Since i recently got my laptop reformatted, the "safely Remove Hadware" icon appears every time I turn it on. Its very annoying as I have to go thorugh the motions of pressing "stop" and "close" et every time. Also i notice when I press stop it gives me 3 choices; Stop a hardware device/USB mass storage device/Generic Volume E

I go through the motions, just as if I had something plugged in, but i dont!

kc
  • 0

Advertisements


#2
Johanna

Johanna

    The Leather Lady

  • Moderator
  • 3,038 posts
Open your Control Panel, Go to System then Hardware then device mgr and if you have a Drive E enabled that isn't supposed to be there, disable it. It's my guess that while it was in the shop they used an external hd or flash drive or something while working on your machine, and the traces are still there in Windows, so Windows is looking for the missing device and displaying the icon.

Johanna
  • 0

#3
hawthorn

hawthorn

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 203 posts
Johanna

Thanks for reply. I think my flash drive is actually drive E. It is in fact USB Mass storage device that is highlighted when I click on the icon; in properties its Location 0.

kc
  • 0

#4
hawthorn

hawthorn

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 203 posts
Yes its still USB Mass Storage Device that is appearing, but I have nothing attached!

KC
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP