Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Redhat Fedora Core


  • Please log in to reply

#31
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,609 posts
Use chkdsk and do a surface scan. You should be able to access it from "My Computer" and right click on "c:", then I think it is properties and then tools.

The message says you can use "chkdsk /f/r", which can be entered from the start menu, selecting "run" and then type that in.
  • 0

Advertisements


#32
J0hn

J0hn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 65 posts
I right clicked on local Disk(c:) and went to the tools tab, then clicked on "Check Now" and put a check mark on "Scan for and attempt recovery of bad sectors. It was scanning for about 10 minutes or so.

After it was done, I ran "chkdsk /f/r" on run then I recieved the following information:

Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts? <y/n>

I clicked on "Y"

After that I restarted the computer then it brought me to a blue screen. From there on out, I don't know what it was doing but it was checking something. I don't know if it tried to repair something or not. I just left it alone until it finished doing its job.

Then when it was all done, I logged on normally.

From what I was thinking, I thought that everything was all fixed. So I booted the computer with Gparted again to try and resize my ntfs partition, but then again it failed. I still recieved the same information which was this:

ntfsresize -P-i-f-v /dev/hda1

ntfsresize v1.13.0(libntfs 9:0:0)
Failed to set locale, using default 'C'.
Device name :/dev/hda1
NTFS volume version: 3.1
Cluster size :4096 bytes
Current volume size: 41101689344 bytes (41102 MB)
Current device size: 411016919044 (41102 MB)
Checking for bad sectors...
Bad cluster: 0x7bf - 0x7bf (1)
Bad cluster: 0x29ab2 - 0x29ab2 (1)
Bad cluster: 0x9721c - 0x9721c (1)
Bad cluster: 0xc003f - 0xc003f (1)
Bad cluster: 0xc0283 - 0xc0283 (1)
Bad cluster: 0xc04e4 - 0xc04e4 (1)
Bad cluster: 0xc0a14 - 0xc0a14 (1)
Bad cluster: 0xc1500 - oxc1500 (1)
ERROR: This software has detected that the disk has at least 8 bad sectors.
***************************************************************************
WARNING: The disk has bad sector. This means physical damage on the disk
surface caused by deterioration, manufacturing faults or other reason.
The reliability of the disk may stay stable or degrade fast. We suggest making
a full backup urgently by running 'ntfsclone--rescue...'then run 'chkdsk /f/r'
on Windows and reboot it TWICE! Then you can resize NTFS safely by additionally
using the --bad-- sectors option of ntfsresize.

^ Again I don't know what to do. Any more suggestions?
  • 0

#33
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,609 posts
It should take more than 10 minutes to do a surface scan of 40Gb. You might try running it again from "My Computer" and see if it sees anything.

Another option, which is better, is to download a diagnostic program from the maker of the disk and test it that way. That should give you more information and more details.

It might be that the there is a problem with the ntfsresize. The last line of the program says that there is a "--bad-- sectors" option (-b). See http://man.linux-ntf...fsresize.8.html
  • 0

#34
J0hn

J0hn

    Member

  • Topic Starter
  • Member
  • PipPip
  • 65 posts
It's ok now. I have Redhat installed with XP. Here is what I did:

I deleted my old windows partition which was the ntfs, then booted Redhat and resized my ntfs partition and created /ext3 and swap on the new free spaces. After everything was all resized and partitioned, I had to wait until Redhat was ready to install itself, but then I didn't want that just yet so I restarted the computer and took out the Redhat cd and quickly booted with my XP cd.

Then that's when I did a fresh installation of Xp onto the vfat partition. When installation was complete, I installed all of my drivers and utitlities.

After that, I booted the computer with Redhat and started the full complete installation.

From all of this, I didn't use Gparted which was cool, I guess :whistling:

But anyway, just to let you know kemasa that I'm doing alright. Again thanks for spending your time helping me.

Only thing now is to try and get my internet back up and running again. I'll be back with more questions, maybe.
  • 0

#35
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,609 posts
That is the best way to do it!! Good to hear that you got it all done.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP