Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

USB Ports gone bye-bye

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
This problem occurred after leaving my laptop with the kids one evening......big mistake. None of my three USB ports are functioning. I have tried various devices with no response. I checked under device manager to ensure they are enabled and they are and are supposed to be functioning properly. I even uninstalled them and rebooted, and even did a total system restore with the same results. HELP!!

My specs:
Toshiba Satellite A75-S2292
Windows XP with SP2 pack build 2600
Pentium 4 3.20 ghz
60 gb Hard drive.
1 USB on front, 2 on the back.

Any Help would be greatly appreciated.
  • 0




    Retired Staff

  • Retired Staff
  • 11,365 posts
if this were xp media center, I would think that they usb devices were removed improperly (just yanked), and I would point you to this patch


Since it is not Media Center, I have seen a few cases where abrupt removal causes similar issues

start > run


Anything there? Right click, uninstall, reboot
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP