Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Setting up home network


  • Please log in to reply

#1
TheRev

TheRev

    New Member

  • Member
  • Pip
  • 6 posts
Hi guys, hope someone can help before I make myself bald by pulling my hair out!

I've got a desktop (wired connection) and a laptop (wireless) running thru my router. I've run all the network setup wizards, disabled firewalls, both software and on router, given both computers lovely names and got them on same workgroup. My problem is I can't access workgroup computers from either of them. All I get is the annoying windows noise and access denied. I can see the desktop from the laptop but can't connect but I can't see the laptop from the desktop. I've got all the folders I need set for sharing etc, and I've done everything else I can think of (not a newbie, just a mad girl geek hehe) but this is driving me nuts!! I even tried setting up a DMZ on the router.

Now before I go completely mad is there anyone who can help out, I know the answer is gonna be soooo straightforward I'll beat myself up for weeks but until someone says "duuuh" and tells me what it is I think I'll sit in a corner and cry!

Both computers running XP, both running ZA, both running Avast AV, everything in same subnet, blah blah, you know the routine!

Oh yeah, I've been thru all your queries on here, I searched thru pages of stuff before I gave in and posted!

Edited by TheRev, 06 June 2006 - 05:51 AM.

  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi TheRev,

You've actually covered most things so I don't think a "Duuuh" is in order here :blink: And I'm afraid that it's not likely that this will be a straight-forward process :whistling:

On both computers, please goto Start --> Run --> type CMD and press OK --> then type: IPCONFIG /ALL - please post the results here by right-clicking on the Command Prompt window, selecting 'Select All', pressing the Enter key, and then posting on this forum. Alternately, you can save your information to a text file by using the following command: IPCONFIG /ALL > C:\ipconfig.txt -- navigate to that text file, and copy/paste the information from it.

On both computers, please goto Start --> Run --> type regedit and press OK --> Now, navigate to the following Key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
--> With the key Lsa selected/highlighted, in the right-pane, look for the value restrictanonymous (there is a value restictanonymoussam directly below; ensure that you do not select this value.) --> right click this value, select Modify and change the decimal value to 0 (zero) --> Close regedit and reboot the computer. After doing this on both computers, attempt to connect again; are you able to?

If you still can't connect, it may be a good idea to restart both computers into Safe Mode with Networking, and then attempt to connect again, to ensure there is no software getting in the way.

How to restart into Safe Mode with Networking
Please restart your computer and as soon as it starts booting up again continuously tap F8. A menu should come up where you will be given the option to enter Safe Mode, Safe Mode with Command Prompt and Safe Mode with Networking (along with a few others). Please tap the down key until you reach Safe Mode with Networking, and then press the Enter key. Your computer should now boot into Safe Mode with Networking.
  • 0

#3
HaraldR

HaraldR

    Member

  • Member
  • PipPipPip
  • 193 posts
If you are using free vers of zone alarm you must allow router ip addresses into a trusted zone otherwise ZA blocks traffic,doesn't happen on pro version

open zone alarm/ click firewall tab /loop back adapter /click zone /select trusted on both pc's

Edited by HaraldR, 06 June 2006 - 07:13 AM.

  • 0

#4
TheRev

TheRev

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Ok, I've tried all that, LSA key's value was set to zero on both computers.

Text from ipconfig....

Laptop
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\customer>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : evilslaptop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-15-00-2F-ED-C1
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.2.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::215:ff:fe2f:edc1%4
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Lease Obtained. . . . . . . . . . : 06 June 2006 13:49:16
Lease Expires . . . . . . . . . . : 19 May 1938 10:35:07



Desktop
Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Kez>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : kelliescomp
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet
Adapter
Physical Address. . . . . . . . . : 00-15-F2-2C-8A-00
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.2.104
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
Lease Obtained. . . . . . . . . . : 06 June 2006 11:57:53
Lease Expires . . . . . . . . . . : 19 May 1938 08:43:44


Both computers are in trusted zone in ZA, as is router.

When I reboot both in safe mode I can see the laptop on the desktop but not the other way round and I can't connect. Honestly, this has got me puzzled to death! I'm wondering if it might be a setting on my router that's causing the problem more than anything else.
  • 0

#5
HaraldR

HaraldR

    Member

  • Member
  • PipPipPip
  • 193 posts
DHCP and DNS are all set to default gateway
IP Address. . . . . . . . . . . . : fe80::215:ff:fe2f:edc1%4 (wifi?) not sure about wifi but think this is not right
Do a renew
type CMD and press OK --> then type: IPCONFIG /release enter

then IPCONFIG /renew enter

This is what I think it should read(based on my network settings 3pcs)

Laptop
IP Address. . . . . . . . . . . . : 192.168.2.100

DNS Servers . . . . . . . . . . . : 192.168.2.104 (pc)


PC
IP Address. . . . . . . . . . . . : 192.168.2.104

DNS Servers . . . . . . . . . . . : 192.168.2.100 (laptop)
  • 0

#6
TheRev

TheRev

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
IP address is 192.168.2.100 on laptop, the other weird stuff I'm not sure about either! Never seen it before to be honest with you! I think it might have something to do with Teredo and Automatic Tunneling Interface. I had a quick nose round the net and it's something to do with IPv6 and I'm guessing the laptop has it installed and the desktop doesn't, would that make a difference do you think?

On further reading both pcs have IPv6 installed, it comes with XP. So back to the old drawing board on that one!

Edited by TheRev, 06 June 2006 - 08:35 AM.

  • 0

#7
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
If you can't connect whilst in Safe Mode, then let's check your permissions --

Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only

EDIT: And yes.. The appended values are simply caused by the IPv6 protocol; you can safely remove this protocol if you so wish, although it is not necessarily a prerequisite. Steps provided if you choose to remove --

Goto Start --> Programs --> Accessories --> Communications --> Network Connections --> Right click on your Local Area Connection --> Select Properties --> Click on Microsoft TCP/IP version 6 once and press the Uninstall button. Allow it to uninstall, and then restart your computer.

Edited by Dan G, 08 June 2006 - 06:59 AM.

  • 0

#8
TheRev

TheRev

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Hi and thanks for your reply. I'll give this a try n let you know :whistling:
  • 0

#9
TheRev

TheRev

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Apologies for not getting back sooner. I appear to have missing connections somewhere along the line, I'm about to format laptop and desktop and restore my router to factory settings, seems a bit drastic I know but being honest both pcs could do with a fresh start! Let you know how I get on once everything's done.

Edited by TheRev, 14 June 2006 - 03:06 AM.

  • 0

#10
TheRev

TheRev

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
Hi guys n thanks for all your help. A format on both computers half solved the problem, not installing Zone Alarm again helped! I reset my router to factory settings and everything's working ok. I know it's extremely drastic but being honest it was winding me up too much, I lost my temper, had a few beers and waved the XP discs round, it's funny how things seem better after beer :whistling: Anyway, long story short, network is now working the way I want it to, woohoo!
  • 0

#11
LiaoGoren

LiaoGoren

    Member

  • Member
  • PipPipPip
  • 261 posts
Actually I wish I had seen this before you formatted.... your problem was ZA.

For some reason it wants to be a pain in the BUTT when you try to setup a new network, what I had to do was uninstall ZA, set up my network, THEN rein stall ZA.. and it worked great.

ZA is just werid!
  • 0

#12
fawoodward

fawoodward

    Member

  • Member
  • PipPipPip
  • 141 posts
Hehe you're almost 2 years too late to have caught him before formatting .. :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP