Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

gparted and parition problems


  • Please log in to reply

#1
spyke01

spyke01

    New Member

  • Member
  • Pip
  • 5 posts
it all started when i needed a partition for xp pro and ubuntu dapper drake to share, asked around to make sure i could increse the number of partitions i had, and i went for it with the help of ubuntuforums.org, i hit a snag after i got everything in gparted set up like i wanted. when i pushed apply it killed my ntfs partition heres what my

heres what my fdisk gave me before the procedure
Disk /dev/hda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 16843 135291366 7 HPFS/NTFS
/dev/hda2 16844 19346 20105347+ 83 Linux
/dev/hda3 19347 19457 891607+ 5 Extended
/dev/hda5 19347 19457 891576 82 Linux swap / Solaris
After i pushed apply, i got a warning saying that the operation couldnt be performed and that i should restart, i got back into dapper and heres what gparted looks like
http://ubuntuforums....&original=1&c=2

I tried to boot into windows, but of course it doesnt pick up that there is a partition, i tried using testdisk(not going to hot, only 1 option left in it), and now im at the end of my rope, the ntfs partition had a long of stuff i needed(thankfully i keep my business stuff on a flash drive).

Can anybody suggest anything?

*NOTE: you have to use gparted via the live cd(desktop cd for dapper)
  • 0

Advertisements


#2
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,575 posts
You need to go back and create the NTFS partition with the pre-exisiting settings (unless you resized that partition):

/dev/hda1 * 1 16843 135291366 7 HPFS/NTFS

The start is 1, the end is 16843, the filesystem type is 7. It may be that just the type is missing. You can use fdisk to do that, or you should be able to use gparted.

It looks like most of your disk is taken up with the XP partition though.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP