Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Mic problems


  • Please log in to reply

#1
tthsoccer

tthsoccer

    New Member

  • Member
  • Pip
  • 3 posts
Not extremely comp savvy but ive tried 3 different mics that work on other computers and wont work on this one. I have previously used mics on this computer through ventrillo, but now all i get is a fuzzy noise when i try to talk through one (i also try the sound recorder thing so its not just vent), is it something wrong with my sound card, or the port that my mic plugs in to, i use a dell precision m70 running windows xp.
  • 0

Advertisements


#2
Dark_Side

Dark_Side

    Member

  • Member
  • PipPipPip
  • 303 posts
It is possible that the port you are using for your mic is damaged. Can you get any other sound played? (Music, System sounds etc)

DS

Edited by Dark_Side, 11 June 2006 - 07:19 AM.

  • 0

#3
JudeF

JudeF

    Member

  • Member
  • PipPip
  • 10 posts
sounds like a damaged port, i had this same problem, and i still do, try plugging in the second mic port.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP