Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

GLW_StartOpenGL () - Could not load OpenGL Subsystem


  • Please log in to reply

#1
Scitt

Scitt

    New Member

  • Member
  • Pip
  • 6 posts
Ok, So I am trying to Play Soldier of Fortune 2 at my school. Here is what our computers are made of\
Dell OptiPlex GX270
BIOS: Phenoix ROM BIOS Plus Version 1.10 A06
Intell Pentium 4 2.8 GHZ
Nvidia Ge force 4 MX 440 With AGP8X

When I click the game the consol comes up normally then the screen turns back and flashing at the top of the consol in red letters it says:
GLW_StartOpenGL () - Could not load OpenGL Subsystem

then the consol says
SOF2MP V1.02t win-x86 Apr 5 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
E:\Scott\Soldier of Fortune II - Double Helix MP TEST/base/MP
E:\Scott\Soldier of Fortune II - Double Helix MP TEST/base

----------------------
0 files in pk3 files

Running in restricted demo mode.

----- FS_Startup -----
Current search path:
E:\Scott\Soldier of Fortune II - Double Helix MP TEST/demo/MP
E:\Scott\Soldier of Fortune II - Double Helix MP TEST\demo\assets.pk3 (1703 files)
E:\Scott\Soldier of Fortune II - Double Helix MP TEST/demo

----------------------
1703 files in pk3 files
execing sof2mp_default.cfg
couldn't exec sof2mp.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
OS: Microsoft WinXP Service Pack 2 (NT)
CPU Detected: Pentium IV
Pentium IV

---------- Input Initialization ----------
Skipping check for DirectInput
Joystick is not active.
------------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
WARNING: tess.xyz not 16 byte aligned
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
R_Terrain: Shutting down RENDERER terrain.....
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem


------------- Input Shutdown -------------
------------------------------------------

Any help on how to fix this without shutting off the computer would be helpful, I've been told I need to download drivers but I cannot install them without restarting the computer and these computers have deep freeze on them :whistling: .
  • 0

Advertisements


#2
BlackPandemic

BlackPandemic

    Member

  • Member
  • PipPipPip
  • 678 posts
By school computers do you mean that your at like college at it won't work or are these public access computers in high school?

Most public school servers don't allow external installation of programs and if you find a way to install them they usually won't work because the computers aren't exactly fitted with the necessary software to run games, just applications and the internet.
  • 0

#3
Scitt

Scitt

    New Member

  • Topic Starter
  • Member
  • Pip
  • 6 posts
They are high school computers, and the game works on the upstairs computers for some reason, so yeah........
  • 0

#4
BlackPandemic

BlackPandemic

    Member

  • Member
  • PipPipPip
  • 678 posts
That could mean the upstairs computers are older (or newer). But I know that when I was in school it took me and my friend some massive "hacking" to get HL2 on there. So my best advice is to give up, and stick to games on FlashPlayer.com or something similair :whistling:
  • 0

#5
ZEUS_GB

ZEUS_GB

    There's no school like old school!

  • Retired Staff
  • 1,650 posts
Are you sure your allowed to install and play games on the schools PCs?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP