Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

SOLVED: wireless laptop cant access desktop but other way works


  • Please log in to reply

#1
digikiwi

digikiwi

    Member

  • Member
  • PipPipPip
  • 259 posts
It seems to be a not uncommon problem, but none of the fixes I have found worked for me.

Setup:

Desktop on LAN to Netgear DG834G

Laptop uses Belkin F5D7030 wireless card

I have a home network set up which used to work fine. Now, I can access all shared folders on the laptop from the desktop. However I can only access the external USB drive on the desktop but none of the shared folders on the hard disks themselves. When I try to access desktop HD folders I get:

network_error_message_copy.jpg

I am running NOD32, Webbroot Spysweeper, Spybot and Adaware on both machines. Previously both ran Norton Security Suite 2005 and NAV2005 before that, but these are now uninstalled.

The windows firewall is turned off (the router has a hardware firewall).

I've had a look at

- enabling NETBIOS over TCP/IP in both machines

- ensuring the computer browser services are running on both machines

- ensuring that file and print sharing is enabled on both machines

- ensuring that "restrictanonymous" is 0, in registry settings which it was

- ensured that my user and group network settings included, "Administrator, Guest, Everyone, NETWORK"

- checking IRPStackSize in registry but there was no entry for this, and creating a key for it did not change problem.


for anyone else with similar problems, I've been digging around for answers here:

http://forums.micros...teID=1&PageID=3

http://support.micro...om/?kbid=318030

http://support.micro....com/kb/177078/

http://www.michna.com/kb/wxnet.htm


and the these links will explain the checklist above.

I find it really strange that I can access the external disk but not the Hard disk shared folders. :whistling:

Any ideas would be welcomed.


Digikiwi

Any other ideas would be good

Edited by digikiwi, 19 June 2006 - 04:46 PM.

  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi digikiwi -- thank you for using The Waiting Room and not bumping your topic. Sorry for the lack of a response :whistling:

If I were to take a wild stab in the dark, I'd say that the reason why you can connect to the desktop's external HD, but not localised files, is because of software differences between the two. Please restart both the desktop computer and the laptop into Safe Mode with Networking and then attempt to connect to the desktop from the laptop; does the error persist?

How to restart into Safe Mode with Networking
Please restart your computer and as soon as it starts booting up again continuously tap F8. A menu should come up where you will be given the option to enter Safe Mode, Safe Mode with Command Prompt and Safe Mode with Networking (along with a few others). Please tap the down key until you reach Safe Mode with Networking, and then press the Enter key. Your computer should now boot into Safe Mode with Networking.

When in Safe Mode, you should ensure that there is no 'Security' software running, before attempting to connect. If, whilst in Safe Mode with absolutely no security software running, you're still unable to connect, please ensure that all of your permissions are setup correctly -- I doubt this is a permission issue, though, as you can already connect to the external HD.. But it won't hurt to check.
Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only

Once done, restart both machines and try again; same deal? Please post back letting me know.
  • 0

#3
digikiwi

digikiwi

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 259 posts
Hi Dan,

G'day from across the pond. No need to apologise, I know you guys don't prolong answering out of maliciousness nor do you get paid for it, so I do appreciate your time and attention.

Please restart both the desktop computer and the laptop into Safe Mode with Networking and then attempt to connect to the desktop from the laptop; does the error persist?


In safe with networking mode my pcmcia wireless card was disabled so no joy there at all.

Everything in User rights assignment was as you indicated.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled


These two were listed as not applicable on both machines - could this be due to static IP addressing?

Network Access: Let everyone permissions apply to anonymous users --> Enabled


These were disabled on both machines and I changed to "enabled". (Does changing this create potential security issues?)

Outcome: No change. Still have the same access / limitations.

Cheers

Digikiwi

Edited by digikiwi, 19 June 2006 - 05:40 AM.

  • 0

#4
digikiwi

digikiwi

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 259 posts
Hi all

Just a note to say I found the solution myself. It was in the IRPStackSize reg key after all. Most fix-it instructions assume your reg settings are in decimal. The first time I followed instructions as per link below and set the decimal value to 15, but this did nothing. My settings are all in hexadecimal base and I found one forum where the writer entered a hex value of "012" which is "18" in decimal. Hence I again I created the new DWORD key (I removed it after creating it and there being no change the first time) and entered this value of "18" on both machines, to be sure, although you should only need to do it on the one you are trying to access.

Most commonly, it seems, this problem is a relic left behind by Norton AV products. In other words, if they don't change the key value they remove the key altogether.

read here for more info

http://support.micro....com/kb/177078/


Thanks for your help Dan G and I hope I shortcut some wasted hours for other users.

Digikiwi
  • 0

#5
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Nice work there, champ. Thanks for posting such a thorough solution to your problem as well.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP