Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot Browse Internet


  • Please log in to reply

#1
BlackHayate

BlackHayate

    New Member

  • Member
  • Pip
  • 3 posts
Hi, I have a Dell laptop, and my internet isn't working. My cable hooked to router and its working fine. Is there anything you can help with? I checked almost every thing (IP, DNS, etc.) and it says working properly. I think some files that to run internet is missing because I just got some spyware and adware on it (Spyware Quake, securityinternet, Smitfraud) After I removed it, My internet isn't working anymore. I used IE, and I used SpywareDoctor to remove those infections. Please help, thank you.

P.S. When I tried opening Internet, it always stuck on "opening ****" or "waiting for reply" its happend on every site that i goes to. i tried to delete history, cookies, files too, but it didn't work.
  • 0

Advertisements


#2
BlackHayate

BlackHayate

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
I really need help ASAP, please! So I tried to find any website that I can get into, I ended up at www.xanga.com. I can load it but only the top part, and its still keep loading but nothing else can be view. what does this mean? MY laptop need to be able to use internet soon, please help. I use the same router as my desktop computer, so I think it shouldn't be at the router or modem. Please help, Thank You.
  • 0

#3
BlackHayate

BlackHayate

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Hi again, I figured what is missing from my internet. When I tried to check my connection status, nothing come up. No tab, no error. If you don't know what I'm talking about here the picture of what its supposed to show. : Posted Image
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP