Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

All my games are freezing


  • Please log in to reply

#1
kingtop

kingtop

    New Member

  • Member
  • Pip
  • 7 posts
well this like started in the beginning of june. i was play halo pc then i see the game slowing down then freezing and then going back to normal. then it started doing this repeatly and i got annoied and turned off the game and played another. about a week later 5 other of my games started doing the same thing. then kept doing that for a while then it like stopped spreading. then it started to do it to all my games. when i installed a new game about a day later it does the freezing. if someone can tell me what is going on plz help :whistling:

if this is in the wrong place plz tell me i am new to the fourm so i can get this problem fixed.
  • 0

Advertisements


#2
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
please post your systems specs and any steps you have tried in your effort to solve the problem.
  • 0

#3
redalertplzslow

redalertplzslow

    New Member

  • Member
  • Pip
  • 6 posts
removed content
  • 0

#4
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts
I know it's off topic, but forms of forums? I find this place very helpful myself...
  • 0

#5
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
have you scanned for virus? Your problem sounds more like a hw issue but we need to hear back from you in order to proceed.
  • 0

#6
redalertplzslow

redalertplzslow

    New Member

  • Member
  • Pip
  • 6 posts

have you scanned for virus? Your problem sounds more like a hw issue but we need to hear back from you in order to proceed.

i found out that my problem is the patch 1.006 it slows animaions makes lag with em and some times freezes videos on my computer
  • 0

#7
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts
Ah yes, sadly, patches can sometimes make things worse. Take Battlefield 2 for example :whistling: What do you plan on doing? Are you going to reinstall the game without the patch?
  • 0

#8
kingtop

kingtop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
ok umm heres something odd theres a black plug that is connected to my harddrive and it looks like it suppose to be pluged in i think this plug is the proplem i just can't figure where to put it.
  • 0

#9
daniel_c

daniel_c

    Member

  • Member
  • PipPipPip
  • 360 posts
black plug? to ur HDD? thats wierd... how many cables are there to the HDD? there should be 2.. power and the IDE cable

Edited by daniel_c, 27 June 2006 - 08:55 PM.

  • 0

#10
mozzer11

mozzer11

    Member

  • Member
  • PipPipPip
  • 423 posts
It might be the SATA cable, that is a red cable with black plugs on each end.
  • 0

Advertisements


#11
redalertplzslow

redalertplzslow

    New Member

  • Member
  • Pip
  • 6 posts

Ah yes, sadly, patches can sometimes make things worse. Take Battlefield 2 for example :whistling: What do you plan on doing? Are you going to reinstall the game without the patch?

i need it to play online
  • 0

#12
daniel_c

daniel_c

    Member

  • Member
  • PipPipPip
  • 360 posts
does the black cable look like this? Posted Image or Posted Image

Edited by daniel_c, 28 June 2006 - 01:41 AM.

  • 0

#13
kingtop

kingtop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
na it has i think 8 little things where a it should plug in
  • 0

#14
daniel_c

daniel_c

    Member

  • Member
  • PipPipPip
  • 360 posts
do you have SATA?
  • 0

#15
kingtop

kingtop

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
ok i looked in my pc for a while to see where the plug can be i found it and i started my games and the freezing was on. the cord was not a sata it was black cord and plug and it connected to my motherboard and you guys for help if any of you have xfire hit me up

xfire: kingtop
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP