Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem With Steam/CS:S


  • Please log in to reply

#1
Networkman

Networkman

    Member

  • Member
  • PipPip
  • 24 posts
I reformated my computer cause i had an about:blank infection.

I installed CS:S/Half Life 2 and used the same steam account i had last time and now when i try to join a server ... another window opens up in game with the server details and it says my latency is 1024 and whne i click join it just says connecting to server and does nothing.

I also switched from using a normal modem to using a voyager 205 router ... may that have anything to do with it?

Also when i try to host games and servers such as teamspeak i give the IP for others to join and they say they cant. I have also tryed switching my firewall off an it doesnt make a difference.


Help is greatly appreciated.

Thanks
  • 0

Advertisements


#2
ditto

ditto

    - i pwn n00bs -

  • Member
  • PipPipPipPip
  • 1,260 posts
hmmm, i would try browsing the Steam support forums at http://www.steampowered.com
  • 0

#3
Networkman

Networkman

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
I have do you think its got anything to do with my router? or SP2?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP