Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Configuring Router


  • Please log in to reply

#1
Gamer2bn

Gamer2bn

    Member

  • Member
  • PipPip
  • 48 posts
I have been trying to get an http server to run from my pc for a while. I have tried IIS on xp IIS on windows server 2003 2 or 3 apache web servers and a couple other FTP applications. I could never get them to work for some reason . recently I ran a server application for a game on my pc and sometimes it would work sometimes it wouldnt I found that it only worked when my pc was assigned the ip adress 192.168.1.100 so i though maybe if i set my pc to be assigned that ip all the time i could run the server on it. I found it only works internally and as soon as someone from outside my network attempts to connect tthey either time out or receive an error. right now im trying to set it up with windows xp IIS. I have tried connecting a DNS to my ip i have tried to conigure the router a linksys wireless-G model wrk54g. I cant seem to get it to work no matter what i do though right now i have it set to forward port 80 to 192.168.1.100 which i give to this computer by logging everyone else out and logging this comp into the network firstas when i autoassign it i cant do anything else on the pc such as aim and the internet it all becomes disabled. I beleive this is because I don't know what to put for the auto assigned DNS address but for the IP i put

IP ADRESS: 192.168.1.100
SUBNET MASK: 255.255.255.0
DEFAULT GATEWAY: 192.168.1.1

With this setup as the default like i said before i cant go online at all but i can view the site from other comps in my network by typing in the servers local IP and my actual IP i am not sure what that is called but i obtain it from www.whatsmyip.org .

If anyone has any clue as to what i am doing wrong or if it just really isnt possible please tell me.
  • 0

Advertisements


#2
acklan

acklan

    Retired Staff

  • Retired Staff
  • 442 posts
  • MVP
You may have just used the wrong term but you appeared to port forwarded to an internal IP address not another port.

"..right now i have it set to forward port 80 to 192.168.1.100.."


It should be forwarded to another port such as port 8080. You will also have to include the new port in your URL.

Current www.whatsmyip.org
Forwarded www.whatsmyip.org:8080 (Or whatever port you use)

Port 80 is the default HTTP port and if you use another you need to tell the computer what port to look for the server on, in this case port 8080. Here are a couple of resources that my help clear things up.

http://www.portforward.com/
http://www.dslwebserver.com/
http://webdevelopmen....asp?Article=34
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP