Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Microsoft .NET Framework 1.1


  • Please log in to reply

#1
Nikul

Nikul

    Banned

  • Banned
  • PipPipPip
  • 204 posts
I tried to install Microsoft .NET Framework with the file dotnetfx.exe. I get An error message : Microsoft .NET Framework Setup failed. If this problem continues, contact Product Support Services.

I am running XP.

Here is the log,.

[06/29/06,20:41:47] Starting Install.exe
[06/29/06,20:41:47] Parsing switches from commandline: C:\DOCUME~1\user1\LOCALS~1\Temp\IXP000.TMP\Install.exe
[06/29/06,20:41:47] SourceDir: C:\DOCUME~1\user1\LOCALS~1\Temp\IXP000.TMP\
[06/29/06,20:41:47] Install started
[06/29/06,20:41:47] Checking system requirements
[06/29/06,20:41:47] OS: Win 98
[06/29/06,20:41:47] Ver: Gold
[06/29/06,20:41:47] SP:
[06/29/06,20:41:47] Checking Internet Explorer Version
[06/29/06,20:41:47] Looking for 5.0.2919.6307
[06/29/06,20:41:47] Found Internet Explorer Version: 6.0.2600.0000
[06/29/06,20:41:47] Internet Explorer Version is OK...
[06/29/06,20:41:47] System meets minimum requirements
[06/29/06,20:41:47] Checking Windows Installer version...
[06/29/06,20:41:47] Trying to load msi.dll
[06/29/06,20:41:47] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:41:47] msi.dll loaded ok
[06/29/06,20:41:47] Looking for: 2.0.2600
[06/29/06,20:41:47] Found: 2.0.2600
[06/29/06,20:41:47] Windows Installer version ok
[06/29/06,20:41:47] Finished Checking Windows Installer version.
[06/29/06,20:41:47] Trying to load msi.dll
[06/29/06,20:41:47] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:41:47] Looking for mscoree.dll from PDC
[06/29/06,20:41:47] mscoree.dll from PDC is not installed local
[06/29/06,20:41:47] Looking for mscoree.dll from Beta
[06/29/06,20:41:47] mscoree.dll is not installed local
[06/29/06,20:41:47] Trying to load msi.dll
[06/29/06,20:41:47] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:41:47] Installing: C:\DOCUME~1\user1\LOCALS~1\Temp\IXP000.TMP\netfx.msi
[06/29/06,20:41:47] StopDarwinService() - Note: Win9x/Win31 machine, not necessary to stop the darwin service. Continuing with setup...
[06/29/06,20:41:47] Trying to load msi.dll
[06/29/06,20:41:47] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:41:47] Full UI
[06/29/06,20:41:47] Calling MsiInstallProduct() with commandline: REBOOT=ReallySuppress
[06/29/06,20:41:48] MsiInstallProduct() returned 1601
[06/29/06,20:41:48]

[MsiInstallProduct]

ReturnCode=1601
[06/29/06,20:41:48] Preparing Dialog
[06/29/06,20:41:48] Message: Microsoft .NET Framework Setup failed. If this problem continues, contact Product Support Services.
[06/29/06,20:41:49] Install.exe returning 1601
[06/29/06,20:41:49]

[Install.exe]

ReturnCode=1601
  • 0

Advertisements


#2
digikiwi

digikiwi

    Member

  • Member
  • PipPipPip
  • 259 posts
If I recall correctly you need to disable your antivirus to install this (disabling your internet connection until finished). I also disabled my Webroot Spysweeper to make sure.

Does that help at all?
  • 0

#3
Nikul

Nikul

    Banned

  • Topic Starter
  • Banned
  • PipPipPip
  • 204 posts
I turned off my internet, anti-virus, firewall, and antispyware protecxtion. I'm still getting the same error. Could this have anything to do with the problem?> In my services Windows Installer was not On. I turned it on manually, but the same thing occurs.

Also, I tried rightclicking the program and clicked Run As. Then Selcted administrator. This time I got a different log:

[06/29/06,20:43:01] Starting Install.exe
[06/29/06,20:43:01] Parsing switches from commandline: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\IXP000.TMP\Install.exe
[06/29/06,20:43:01] SourceDir: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\IXP000.TMP\
[06/29/06,20:43:01] Install started
[06/29/06,20:43:01] Checking system requirements
[06/29/06,20:43:01] OS: Win NT
[06/29/06,20:43:01] Ver:
[06/29/06,20:43:01] SP:
[06/29/06,20:43:01] Checking Internet Explorer Version
[06/29/06,20:43:01] Looking for 5.0.2919.6307
[06/29/06,20:43:01] Found Internet Explorer Version: 6.0.2600.0000
[06/29/06,20:43:01] Internet Explorer Version is OK...
[06/29/06,20:43:01] System meets minimum requirements
[06/29/06,20:43:01] Checking Windows Installer version...
[06/29/06,20:43:01] Finished Checking Windows Installer version.
[06/29/06,20:43:01] Trying to load msi.dll
[06/29/06,20:43:01] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:43:01] Looking for mscoree.dll from PDC
[06/29/06,20:43:01] mscoree.dll from PDC is not installed local
[06/29/06,20:43:01] Looking for mscoree.dll from Beta
[06/29/06,20:43:01] mscoree.dll is not installed local
[06/29/06,20:43:01] Trying to load msi.dll
[06/29/06,20:43:01] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:43:02] Installing: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\IXP000.TMP\netfx.msi
[06/29/06,20:43:02] Checking IIS...
[06/29/06,20:43:02] IIS not found
[06/29/06,20:43:02] Checking MDAC Version
[06/29/06,20:43:02] Looking for 2.70.7713.0
[06/29/06,20:43:02] Found MDAC Version: 2.70.7713.0
[06/29/06,20:43:02] MDAC Version OK
[06/29/06,20:43:02] StopDarwinService(): Darwin service successfully stopped
[06/29/06,20:43:02] Trying to load msi.dll
[06/29/06,20:43:02] Loading: C:\WINDOWS\System32\msi.dll
[06/29/06,20:43:02] Full UI
[06/29/06,20:43:02] Calling MsiInstallProduct() with commandline: REBOOT=ReallySuppress IIS_NOT_PRESENT=1
[06/29/06,20:43:03] MsiInstallProduct() returned 1601
[06/29/06,20:43:03]

[MsiInstallProduct]

ReturnCode=1601
[06/29/06,20:43:03] Preparing Dialog
[06/29/06,20:43:03] Message: Microsoft .NET Framework Setup failed. If this problem continues, contact Product Support Services.
[06/29/06,20:43:04] Install.exe returning 1601
[06/29/06,20:43:04]

[Install.exe]

ReturnCode=1601




Note: I was always logged on the administrator account, even for the first log. I will now try installing this in safe mode.
  • 0

#4
Nikul

Nikul

    Banned

  • Topic Starter
  • Banned
  • PipPipPip
  • 204 posts
I tried It in Safemode. I get the same error. Maybe this will help. I checked the Event Viewer, This is the description I got for the installer failier.:

Event Type: Warning
Event Source: MsiInstaller
Event Category: None
Event ID: 1015
Date: 6/30/2006
Time: 12:03:01 PM
User: N/A
Computer: USER1
Description:
Failed to connect to server. Error: 0x80040154

For more information, see Help and Support Center at http://go.microsoft....link/events.asp.
  • 0

#5
Nikul

Nikul

    Banned

  • Topic Starter
  • Banned
  • PipPipPip
  • 204 posts
I fixed it. I had to go to command prompt. CD to C:\windows\system32

Then typed msiexec.exe /regserver

thnx anyways.
  • 0

#6
digikiwi

digikiwi

    Member

  • Member
  • PipPipPip
  • 259 posts
Nice to see you post the solution, it's bound to help others. If only everyone could do that...
  • 0

#7
inouk79

inouk79

    New Member

  • Member
  • Pip
  • 1 posts
It helped me! Thanks alot!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP