Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Need help ! {War of Warcraft!}


  • Please log in to reply

#1
beav3r

beav3r

    Member

  • Member
  • PipPip
  • 35 posts
Well i just bought world of warcraft, and finished installing it....I load it up and like the screen is all fuzzy and laggs!....And ideas?


Thx
  • 0

Advertisements


#2
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
What do you mean fuzzy and laggs?Did you log in the game and it lags or does it lag right on the title screen?

Edited by Snippy, 08 July 2006 - 02:05 PM.

  • 0

#3
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
It laggs on title screen
  • 0

#4
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
What are your system specs?And do you got xfire?it would be alot easier for me to help you =)

Edited by Snippy, 08 July 2006 - 02:14 PM.

  • 0

#5
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
Erm lol how do i find that?
  • 0

#6
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
http://www.systemreq...referrer/srtest

Go there then select world of warcraft from the drop down list and run the test and it will check to see if your system can run wow properly.
  • 0

#7
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
Wow thx, i now know that i have all the things needed to run it....I got a pass?.....Hmm but it's like still fuzzy the screen ....weird....I myt needa make an acc first i just bought da game?
  • 0

#8
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
no that wouldn't help making an account but just try restarting your computer then tryng to bring up the game agian but if you pass everything in the test then it should work .
  • 0

#9
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
Ok cherz 4 helping!
  • 0

#10
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
So is it still laggy?
  • 0

#11
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
Add me on xfire if you need more help. Xfire===> snippyman
  • 0

#12
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
Whats xfire........Soz lol i'm new to this.....(stuff)
  • 0

#13
beav3r

beav3r

    Member

  • Topic Starter
  • Member
  • PipPip
  • 35 posts
Do u need direct x 9.0c or summin to play?.....Well i have made an acc.......Try to logg in but all i get is ........Connecting...(It does not connect).Any suggestions?
  • 0

#14
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
Go to www.xfire.com and download it creat an account and add me. My xfire is snippyman.
  • 0

#15
BlackPandemic

BlackPandemic

    Member

  • Member
  • PipPipPip
  • 678 posts
Snippy, try and help him fix his game, not get him to download more things.

Yes beav, you will need DirectX 9.0c to run WoW. Also, if you could post your specs (processor, RAM, video card, etc.) that would help a great deal.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP