Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Networking/File Sharing Problems


  • Please log in to reply

#1
professor kirke

professor kirke

    Member

  • Member
  • PipPip
  • 10 posts
I read and followed the tutorial here, and I am still unable to get a network working in our house.

We have two families living here sharing 4 computers:

Desktop A is wired to the main router.
Desktop B is wireless.
Laptop C is wireless.
Laptop D is wireless.

I have run all of the file sharing steps for all four computers, and the following happens:
  • Desktop A cannot see any other computer on the workgroup, even under "View workgroup computers."
  • No other computer can see Desktop A, even under "View workgroup computers."
  • Desktop B, Laptop C, and Laptop D can all see each other under "View workgroup computers."
  • When Desktop B tries to access Laptop C or D, an error message appears saying "You do not have permission."
  • When Laptop B or C tries to access Desktop B, an error message appears saying, "You do not have permission."
  • Laptops B and C have full access to each others' shared folders and files, as planned.
All 4 computers run Windows XP, and have access to the internet through the same wireless router, connected to a Comcast cable modem. It is a Linksys Wireless-G router.

Any and all help with this problem would be appreciated -- the only goal is to share files between all four computers and to share the two printers (there is a printer connected to each Desktop computer).

Thanks.

Jason

Edited by professor kirke, 10 July 2006 - 03:53 PM.

  • 0

Advertisements


#2
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Hi Jason,

The most common cause for this is a firewall -- try temporarily disabling all third-party firewalls on all of the computers. Also, if you're using XP SP2, you will need to shut down the inbuilt Windows firewall; to do so, do the following on all of the computers:

Goto Start --> Settings --> Control Panel --> Click on Security Center --> Select Windows Firewall --> Select Off (not recommended) and then click Apply.

Now, goto Start --> Run --> Type Services.msc --> Scroll down to Windows Firewall/Internet Connection Sharing (ICS) --> Right-click and select Properties --> Change the Start-up type to Disabled and then click the Stop button --> Press Apply and then close those windows. Restart your computer; upon reboot, the Windows Firewall will no longer be running.

Once done, try connecting the computers again; are you able to?
  • 0

#3
professor kirke

professor kirke

    Member

  • Topic Starter
  • Member
  • PipPip
  • 10 posts
During the entire initial networking prodedures I'd had all firewalls turned off, including the Windows SP2 firewall. I've gotten Desktop B to connect with Laptops C and D by disabling ZoneAlarm completely from Desktop B. Those 3 computers are now networked perfectly.

The problem, still, is Desktop A, which is the only hard wired computer on the network. It isn't even visible from any of the other computers (In "view workgroup computers" etc). Desktop A doesn't have ZoneAlarm or any other 3rd party firewall, and I've disabled the Windows SP2 firewall--still nothing.

Should I post a HijackThis log? Or do you have other simple suggestions to try first? I've got no other ideas...
  • 0

#4
Dan

Dan

    Trusted Tech

  • Retired Staff
  • 1,771 posts
Please try creating a brute connection to Desktop A; to do this, goto Start --> Run --> type \\IP\Drive\Folder -- where IP is Desktop A's IP Address, Drive is the drive which you have shared folders on, and folder is a folder which you have shared.. eg: \\192.168.0.101\D\My Music -- to find A's IP Address, goto Start --> Run --> type ipconfig and press enter; it will be listed there. Are you able to connect to A via this method?

On Desktop A, please goto Start --> Run --> type regedit and press OK --> Now, navigate to the following Key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa
--> With the key Lsa selected, in the right-pane, look for the value restrictanonymous (there is a value restictanonymoussam directly below; ensure that you do not select this value.) --> right click this value, select Modify and change the decimal value to 0 (zero) --> Close regedit and reboot the computer. Attempt to connect to A from one of the other computers; are you able to?

Also, check A's permissions -- Start --> Settings --> Control Panel --> Performance and Maintenance --> Administrative Tools --> Local Security Policy --> Expand Local Policies --> Select User Rights Assignment

Now, check the following:
Access this computer from the network --> Ensure that Administrator, Guest and Everyone is on this list; if not, choose Add User Group and add them.
Deny access to this computer from the network --> Ensure that Everyone and Guest are not on this list.
Deny logon locally --> Ensure that Guest is not part of this list.

Now, under Security Options, check the following:
Accounts: Administrator account status --> Enabled
Accounts: Guest account status --> Enabled
Network Access: Let everyone permissions apply to anonymous users --> Enabled
Network access: Sharing and security model... --> Guest only
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP