Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Scanner not found - Windows 98SE

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
I have a NEW COMPUTER (‘NC’ with USB2 ports and Windows XP) and an OLD Computer (‘OC’ with USB1 ports and Windows 98SE). They are connected to the same monitor via a Belkin Omniview KVM Switch (F1DK102uuK) which is working reasonably ok.

The Belkin switch is connected to the OC via a USB 4 port hub. The hub is working properly, because I am able to download pictures successfully via this connection to my OC. However, I cannot get my Scanner (Packard Bell PB 61236) to work on my OC, whether it is via this connection, or directly into one of the USB ports at the rear of the computer. When I try to ‘acquire’ the scanner in my imaging software (Photo Express) the answer is always ‘scanner cannot be found, even though I know that the scanner is working because its light is on. I have tried un-installing and then re-installing the scanner driver many times but still no success.

After I boot up OC, two problem devices always appear in the Add New Hardware Wizard – ‘Unknown Device’ ‘USB Human Interface Device’

The details of ‘Unknown Device’ are:
Icon: Red Cross in its icon
Device Type: Universal Serial Bus Controller
Manufacturer: (Standard USB Host Controller)
Hardware Version: Unknown
Device Status: This device is disabled (Code 22). Click ‘Enable Device’ to enable this device’
Device Usage: ‘Disable in this Hardware Profile’ is ticked but not ‘Exists in all hardware profiles’.

No matter what route I follow (‘Search for better driver’ or ‘Display a list of all the drivers in a specific location…’ or ‘Show Compatible Hardware’) the driver I end up with is always C:\WINDOWS\INF\USB.INF. and my scanner is still not recognised. Clicking on ‘Enable Device’ seems to do nothing (no wizard appears and my screen usually freezes).

The details of ‘USB Human Interface Device’ are:
Icon: Yellow exclamation mark in its icon
Device Type: Human Interface Device
Manufacturer: (Standard Device)
Hardware version: Not available
Device Status: This device is either not present, not working properly or does not have all the drivers
installed (Code 10). Try updating driver
Device usage: ‘Disable in this hardware profile’ is not ticked but there is a tick in ‘Exists in all
hardware profiles’

Again no matter what route I follow the driver I end up with is always C:\WINDOWS\INF\HIDDEV.INF. I can re-install this driver from ‘Base 5.cab’, which installs successfully, and the device is then stated to be working properly, but as soon as I re-boot, it becomes a problem device again.

Can anyone help me please. My NC is connected to the Internet, but not my OC, therefore I have to download to NC, copy to disc and install manually on my OC.


  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP