Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Power Problems


  • Please log in to reply

#1
opdude

opdude

    New Member

  • Member
  • Pip
  • 1 posts
Hey there,

I just bought a new motherboard and psu, and they dont seem to work together ..

The PSU is a Seasonic S12 (430 Watt), and the motherboard an Asus A8N-SLI SE.

When ive connected it all up and turned on the power swtich on the psu the power light on the motherboard turns on once for about 0.5 secs and then turns off again. I wondered if it was the PSU but i tested this on my current computer and it worked fine. I also tested the motherboard with another psu (Only a 20 pin psu unlike the new one which is 24 pin) and that worked.


So what gets me is they both work, but why wont they work together?

Thanks in advanced

Daniel Hobley
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP