Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

GnuPG Problem

  • Please log in to reply




  • Member
  • PipPip
  • 65 posts

I have a problem. I have 2 computers and I set one up with GnuPG(GPG) with a key. I use Thunderbird to send and receive encrypted email with no problems. The second computer is not set with any key. I want to setup the second computer with with the "Same" email like the first computer with a key, but it doesn't work. When I start to generate my key, it fails. Here is what I did.

I typed in my name, enter the "Same" email, basically everything is all the same. Once I entered my pass phrase, it starts generating the key. After a couple of minutes, I get the below error.
gpg: no writable public keyring found: eof 
Key generation failed: eof 
gpg: can't create `C:/GnuPG\random_seed': No such file or directory 
*My path variable under mycomputer/properties/path is the following*
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;;"C:\Program Files\Zone Labs\ZoneAlarm\MailFrontier" 
Some people add the path ";c:\program files\GNU\GnuPG" after MailFrontier or whatever their path is set to, but I'm assuming that I don't need to do that because on my other computer it is setup with GnuPG and has the same path as mentioned above and still everything is ok.

I'm all out of ideas on how to fix this. I've googled all day and I found a few people with the same problem, but theres were in linux and mine is in Windows. The solution for linux was to make sure it had read and write access(something similar to that) and a few other things which looked pretty easy to fix by the way. I tried grabbing some of those hints and applying them to Windows, but it doesn't seem to work. It was at least worth a try tho......... :whistling:

But so far I've found nothing related to Windows. That's about all the information I can think of right now.

PS, If there's a way to fix this, please inform me. Detailed instructions would be nice by the way.

Thank You.

Windows XP and latest version of GnuPG

Phewww, everything is fixed now I'm so relieved.


Uninstall everything and delete everything that's related to GnuPG. Then go to start/run/regedit and surf the following registry. Delete the 2 GnuPG folders.



Install GnuPG again. During installation, default PATH SHOULD be c:\program files\GNU\GnuPG on an English Windows XP box. Now test the installation to see if it is installed correctly. Go back to start/run/cmd and type the following:

gpg --version

You should see a screen of information which should look similar to this:

gpg (GnuPG) 1.4.1
Copyright © 2005 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Home: C:/Documents and Settings/bporter/Application Data/GnuPG
Supported algorithms:
Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512
Compression: Uncompressed, ZIP, ZLIB, BZIP2

If you get the error Wrong command or file name , then you did not set up the PATH correctly.

Edited by J0hn, 18 August 2006 - 04:09 PM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP