Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

D-Link DSL-G604T ADSL router can't access internet


  • Please log in to reply

#1
multiplex77

multiplex77

    Member

  • Member
  • PipPip
  • 20 posts
I installed my new D-Link DSL-G604T ADSL router according to the instructions in the manual. My PC is connected to the router using an Ethernet cable (RJ45). I'm using PPPoE (Singnet broadband in Singapore). I've entered in my correct username and password, and restarted the router after completing the setup. However I can't connect to the internet -- I can't ping websites or access my email.

I was able to access the Internet earlier and was even able to get my wireless connection on my laptop working, but after I entered a MAC address in the router configuration, the Internet connection went down and I can't get it connected again no matter what I try (I've been trying for the last 6 hours!).

I have no problems logging in and accessing the router configuration page through my browser. But when I try to access websites on my browser, it just cannot connect (basically there is no internet connection, as I can't even PING).

My PC is using Windows 2000 Pro. My laptop is using Win XP Pro.

My ipconfig/all is as follows:

Windows 2000 IP Configuration

Host Name . . . . . . . . . . . . : multiplex
Primary DNS Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-0C-76-99-85-DF
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . :


Please, can someone help me? Thanks very much in advance!
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
You don't have a gateway. Go into the same dialog where you set the IP address to 192.168.1.2 and either add the gateway value (192.168.1.1) in there, or alternatively turn DHCP on (which can be done by just telling Windows in the same place to obtain an IP address automatically).
  • 0

#3
multiplex77

multiplex77

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Thanks Neil for your reply. I did what you advised (with a little help from D-Link customer service) and it works now. For the benefit of others encountering the same problem, this is what I did:

Reset the router back to factory default settings (on hindsight this was probably not necessary, but it won't hurt to do it just to be sure):

1. Power On the router.
2. To reset the router, use a pin/paperclip, press and hold the reset pinhole at the back of the router for 10 seconds.
3. Release the pin and wait for around 30 seconds.
4. You can now login to the router's configuration page (192.168.1.1).
5. Default username & password are both admin.

Reconfigure the router again.

Configure the computer to obtain an ip address automatically, not in the router.

Step 1 Click on the Start button, click Settings then Control Panel.
Step 2 Double-click the Network and Dial-Up Connections icon.
Step 3 Right-click the Local Area Connection icon then select Properties.
Step 4 Double-click Internet Protocol (TCP/IP).
Step 5 Select "Obtain an ip address automatically".
Step 6 Under "Use the following DNS Server Addresses" input the following information:
Preferred DNS=165.XX.XX.XX
Alternate DNS=165.XX.XXX.XX
Step 7 Click OK. On the previous page, click OK.

Restart the router (WAN -> Reboot)
  • 0

#4
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
Are you using a Modem or is this a fiber connection? If a modem is in the equation you will need to bridge the modem. your ISP should be able to give instructions.
  • 0

#5
multiplex77

multiplex77

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I'm using a modem connection, connecting using PPPoE. Seems to be working fine now. Thanks.
  • 0

#6
paws

paws

    WTT Tech Teacher

  • Tech Academy Moderator
  • 523 posts

Hi joseph121 and welcome to our forums.

 

 

Its good to see  that you are offering advice on the forums here, but just a word to the wise.....do check the age of the topic and the dates of the posts.... as you are posting potential solutions to topics that are 7 or 8 or sometimes 10 years old .....

 

Don't be disheartened though, but do check the dates!

Regards

paws


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP