Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

HELP - EXTERNAL HARD DRIVE


  • Please log in to reply

#1
?????

?????

    Member

  • Member
  • PipPip
  • 74 posts
today i went to switch on my external hard drive and when i clicked into it my folders didnt come up and then i tried unplugging it and that aswell and then it started coming up with the message saying .. " one of the USB attached to this computer has multifunctioned and windows dosent recognise it ... i tried clicking the bubble that comes up nothing happend plus i didnt get a disc to install it with so what can i do ? does this mean i have lost my files to ? if y es is there anyway i can get them back?
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP