Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Age of Empires 3 / Please Help


  • Please log in to reply

#1
glen88

glen88

    Member

  • Member
  • PipPip
  • 17 posts
Hey,

I am trying to get Age of Empires 3 to run on my computer and it will either restart (after sometime - could be upto 20 minutes) or exit. I have had this problem on another computer, but thought it was the graphics card.

Age of Empires system requirements are:

- Microsoft Windows 98, ME, 2000, XP
- 128 MB of RAM
- Pentium 800 MHz or equivalent
- 64 MB 3D video card
- 1.5 GB of free hard disk space
- 32x CD-ROM drive
- DirectX 8.0 compatible sound card
- 56 kbps Internet connection for online play

Recommended system requirements:

- 512 MB of RAM
- 2.0 Ghz CPU
- 128 MB 3D video card

My Computer

* Mainboard: Gigabyte 7n400pro2

* CPU: Athlon XP 2600+

* RAM: 2x Corsair PC3200 DDR 256MB LL = 512MB total

* Graphics: GeCube Radeon 9800 Pro 128Mb

* Hard Drive: Seagate 7200rpm 80GB

* Optical Drive: Liteon SOHW-812S 4X DVD+/-RW Drive (firmware upgradeable to dual layer?)

* Case: Antec SuperLanBoy 350 (incl 350W Antec SmartBlue Power Supply Unit, dual 120mm fans - front and rear, toolbox, carry strap)

* CPU Cooling: Tower Heatsink/Fan with heat-pipe technology with 2x80mm fans - blows straight out of case via rear case fan

* XP Professional
-

I dont see a problem with this, is there something I should download or any hardware upgrades I should get?

Please Help!

Thanks

edit:

Have also put DirectX 9 on, HVision, and ATI - all components I downloaded from the Radeon website.

Edited by glen88, 02 September 2006 - 11:37 PM.

  • 0

Advertisements


#2
elmundo

elmundo

    Member

  • Member
  • PipPipPip
  • 146 posts
sorry wrong forum

Edited by elmundo, 02 September 2006 - 11:50 PM.

  • 0

#3
h_mike

h_mike

    Member

  • Member
  • PipPipPip
  • 344 posts
This is the correct forum for his Age of Empires issue.
  • 0

#4
Facedown98

Facedown98

    Trusted Tech

  • Technician
  • 2,989 posts
Are your video card drivers up to date? Does the manufacturer of the game have any support documents we can view on this?
  • 0

#5
h_mike

h_mike

    Member

  • Member
  • PipPipPip
  • 344 posts
Yes, basically we need you to update your drivers, you'll also need to make sure you have the latest Direct X, which is Direct X 9.0c. I want you to uninstall Age of Empires, then restart your computer, then re-install the application. If that doesn't fix it, I want you to go to Add/Remove Programs and select Age of Empires 3, from there I want you to click "Repair". This will overwrite, or fix any corrupted files. If that doesn't fix it, come back and tell us.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP