Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Dont seem to have boot.ini file


  • Please log in to reply

#1
Unsuremoog

Unsuremoog

    New Member

  • Member
  • Pip
  • 4 posts
I have done a search for boot.ini and have only come with boot.ini.backup. Which looks identical to what is shown by msconfig.exe under the boot.ini tab. Why cant I find boot.ini?

I am trying to get rid of an unwanted selection to setup win2000 during boot. You know like the dual boot option. I left the Win2000setup CD in the drive once and it started making a second copy. I only need the original operating system and not the one that is ready to be setup every time I reboot. Maybe someone has a better way to solve this problem than editing boot.ini - which I dont know how to do or how to find. Any answers or advice, I would be very greatful.
  • 0

Advertisements


#2
Pi rules

Pi rules

    Member

  • Member
  • PipPipPip
  • 634 posts
Welcome! :whistling:

Boot.ini is a "hidden" file, so you cannot see it by default. Open My Computer and go to Tools | Folder Options. Click the View tab and find "Hidden Files and Folders" and select "Show hidden files and folders".

When performing the search, under Advanced Options, make sure that "Show hidden files and folders" is checked.

boot.ini should be under C:\boot.ini

You could also go to Start | Run and type notepad C:\boot.ini, which will open the boot.ini file in Notepad (text editor) to edit the file.
  • 0

#3
Unsuremoog

Unsuremoog

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Thanks. I can access from <run> notpad C:\boot.ini :whistling: The trouble is, I can't edit it, as I cannot change the attributes from read only. Hidden files are being showen just not this one. Advanced search options include search subfolders, case sensitive and search slow files but nothing about hidden files. There's also text I can display with <run> notpad F:\boot.ini. Bootable windows files are on F drive. Well windows is on F drive.

C:\boot.ini is

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

F:\boot.ini has

[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows 2000 Professional Setup"

Hope this is of some help. Thanks again.
  • 0

#4
Pi rules

Pi rules

    Member

  • Member
  • PipPipPip
  • 634 posts
Let's try to change it from read-only then. Please go to Start | Run and type cmd.exe. This will bring up a command prompt. Once there, type
attrib -s -h -r C:\boot.ini
and press enter. This removes the System, read-only, and hidden attributes for boot.ini. Please make sure to reset the system and hidden attributes when finished; I'll provide instructions. Do the same for F:\boot.ini.

Then, edit F:\boot.ini to look like C:\boot.ini and save it.

Once you are done, go back to Start | Run | cmd.exe and type:
attrib +s +h C:\boot.ini
press enter, and do the same for F:\boot.ini. This restores the System and Hidden attributes.
  • 0

#5
Unsuremoog

Unsuremoog

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Thats [bleep] brilliant. I edited boot file in F drive wrongly to start with and got a bit worried, but now it works great. Im impressed. Thank you.
  • 0

#6
Pi rules

Pi rules

    Member

  • Member
  • PipPipPip
  • 634 posts
No problem. :whistling: I'm glad it worked out for you.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP