Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

not sure what happened


  • Please log in to reply

#1
perkowski

perkowski

    New Member

  • Member
  • Pip
  • 1 posts
I went to apply new thermal compound to my CPU and when i went to boot up, my fan sounded like it was going about 8x faster than usual and very powerful. No signal would be sent to my monitor, my mouse/keyboard wouldnt light up, nothing works. I think it is the motherboard that is the problem. before i go get a new mobo, i would like to see what you guys think is the problem.

thanks
  • 0

Advertisements


#2
hudihoo

hudihoo

    Member

  • Member
  • PipPipPip
  • 298 posts
The problem could be related to any of the following: Mobo;ram;cpu;power supply. You should probably isolate the problem and find out which exactly is wrong before you try to fix it.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP