Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Generic Host Processes for Win 32


  • Please log in to reply

#1
dawillie

dawillie

    New Member

  • Member
  • Pip
  • 3 posts
report_about_the_generic_host_process.JPG

:tazz:

Writing on behalf od a friend in Eastern Europe with a 10 hr. time differential.
O/S is Win XP Home-SP2.

She advises that she periodically gets the following error message 'Generic Host Process for Win 32 series has encountered a problem and needs to close'.

She is presented with a Microsoft error reporting window and after she does so, the error message screen disappears and nothing else happens. That is to say the PC does not shut down.

She has sent me a screen shot of both error messages which i am appending to this post.

The language is Russian however the tech details which I will post are in Englsih.

Error Message Screen
sz AppName svchost.exe szAppVer 0.0.0.0 sz Mod name Unkown sz Mod ver 0.0.0.0 offset 00000000

Technical details

c:\windows\TEMP\WER9ec7.dir00\svchost.exe.mdmp

c:\windows\TEMP\WER9ec7.dir00\appcompat.txt

I have read on some of the issues surrounding these and advise that she does not have HP printer, but has Nero Software burning installed.

I would appreciate being advised as to a fix.

As I am precluded from telephone communication, I would appreciate recieving step by step instruction to reslove as I will be C&P in an email to her.

Thank you n advance.

david williams
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
David, these:

c:\windows\TEMP\WER9ec7.dir00\svchost.exe.mdmp
c:\windows\TEMP\WER9ec7.dir00\appcompat.txt

are really not technical details, but the files that are sent to Microsoft use to assist in debugging. They are the svchost minidump and (I think), a list of applications running at crash.

svchost, as the name implies, is is a system process that handles processes executed from DLLs...DLLs are dynamic link libraries that are not executable programs by themselves, but have code that is generally accessed by other programs...

So, for example, windows explorer is your file manager, but there is nothing in it that allows it to drag and drop a file from one folder to another. Instead, explorer goes and uses the instructions in a dynamic link library so it can do that.

Sometimes, windows doesn't have a user application, but needs to accomplish some code from a DLL. so svchost becomes the executable, and it accesses code/instructions in the DLL.--or some DLL code may access something in other DLLS or executables to accomplish a task

So, what does this mean for your friend? It means that some DLL has bad code, or something is wrong with a windows executable.

Most of these problems are related to a malware infestation, so if you can get your friend to run hijack and send you the info so you can post a log, we can either rule that and move on or fix it.
  • 0

#3
dawillie

dawillie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
thank you Gerry.

where can i find the link to 'Hijack This'.

david williams
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
http://www.geekstogo...action=cat&id=3
  • 0

#5
dawillie

dawillie

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
thank you.

sending link, to d/l and post to file and send.

back n 2 days, I hope.
  • 0

#6
Marky

Marky

    New Member

  • Member
  • Pip
  • 2 posts
Hi I am a new member signed up just bacause of this post I am having the EXACT same problem on one of my machines is haveing this problem and it driveing me up a wall, I have a FoxConn Motherboard K7S741GXMG-6L and a Sempron 2400+ CPU I did a fresh load on the system and the problem only started happening after I load SP2 not sure if that has anything to do with it, the only programs installed are WinRah Nero 6 & Adobe Reader. So I am very curious to see how this turns out.
  • 0

#7
Marky

Marky

    New Member

  • Member
  • Pip
  • 2 posts
Forgot to add I installed all the same software on and Intel machine ate the same time and that one is fine.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP