Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Stop PC from booting from Pendrive


  • Please log in to reply

#1
charliewykes

charliewykes

    Member

  • Member
  • PipPip
  • 84 posts
Hi,

I have a PC with an ASUS K8V mobo and two hard drives. One came with it and holds Win XP SP2. Its listed in the bios as Primary Slave. The other is an old one I aded as a backup device and as long as I specify that the primary slave is the first hard drive to boot from I have no problem.

But, I've got a new 1G USB pendrive which, if I forget to take it out before booting up, overides the boot order and either becomes the 1st 'hard drive' to boot from or worse seems to make the backup drive undectable in windows which screws up my overnight backups. I can go into the BIOS and reset the priority but its irritating. Is there a way I can instruct the BIOS to ignore the thing as a boot device (I've tried disabling all removable drives as boot devices to no avail) or format/add something to the pendrive that will have the same effect?

Thanks
  • 0

Advertisements


#2
fleamailman

fleamailman

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,383 posts
hi, welcome to geeks
just an idea but remove invalid boot device
and

to delete an invalid bootpath:

run command
- press keyboard buttons: winkey + r button
- paste this: msconfig
- press: enter
- click tab: boot.ini
- click button: check all boot paths
(computer checks the boot paths and removes invalid one)

Edited by fleamailman, 18 October 2006 - 01:20 PM.

  • 0

#3
charliewykes

charliewykes

    Member

  • Topic Starter
  • Member
  • PipPip
  • 84 posts
Hi,

Thanks for this but no joy. I think the problem is in the BIOS. I can't stop it from changing the boot order when the pendrive is plugged in at bootup. Any ideas on how to force the BIOS to retain the settings I want welcome!!

Cheers
  • 0

#4
fleamailman

fleamailman

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,383 posts
remember I am working blind so bare with me
- what is the boot sequence at the moment
  • 0

#5
charliewykes

charliewykes

    Member

  • Topic Starter
  • Member
  • PipPip
  • 84 posts
Ok - the boot sequence is floppy/CD/hard drive. That's fine, the first two are ignored unless there's a floppy in the drive or a bootable CD. As for the hard drive... there is an option in the BIOS to specify the hard drive order

The PC came with a hard drive shown as a primary slave from which it booted. This was not connected by the familiar (to me) ribbon cable but by a thick round cable - I guess a few years ago this was the next step in connectivity. I stuck in an 'old' hard drive onto the ribbon cable that was available in the PC. The BIOS immediatley assigned that 'old' hard drive as no. 1 in the hard drive order but I reversed the order and no problem, the machine booted from the drive it came with and the 'old' one was assigned a letter. I could shut down without the hard drive order changing. Presumably because the 'old' one was never removed.

The problem with this pendrive is that if it's in the machine at boot up the BIOS sees it as a hard drive and it always becomes the first hard drive of three. As was the case with the 'old' hard drive above, I can instruct the bios to treat it as number two or three and it will stay there until removed but of course I do remove it and then inadvertantly leave it in now and again and thus the BIOS sees it as new hardware and gives it position 1 in the hard drive list/

Therefore to solve the problem think I either need to stop the BIOS seeing it as new hardware (or as a hard drive) OR stop the BIOS changing the hard drive order when it detects a new 'hard drive'. (Or would having the origional hard drive set as a primary master not slave help??). Thing is, I don't know how...

Hope the above makes some sense,

Cheers
  • 0

#6
fleamailman

fleamailman

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,383 posts
it is making very clear sense to me but I too can't see why it is doing this, why would the cable you mention have this effect, sorry I am not being much help here
  • 0

#7
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
Should be an option for the boot order of hard drives in the BIOS. What it looks like is that removable drives are set to boot before the Internal drives. You just need to change that sequence and everything should be fine.

Fenor
  • 0

#8
fleamailman

fleamailman

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,383 posts
I believe you mention that has already been tried and that although you put the boot sequence correctly the computer interprets the exteranl harddrive for an internal harddrive and boots to it frist

tell me more about this cable then, can it not be changed for a normal one
  • 0

#9
jrm20

jrm20

    System building expert

  • Retired Staff
  • 2,394 posts
I have an option called Boot other device in my bios and if you put that to disable it should override the usb flash drive all together "on bootup".

Do you have an option called Boot other Device? If so the only thing I can think of is to put that to Disable since you seemed to try everything already. :whistling:
  • 0

#10
charliewykes

charliewykes

    Member

  • Topic Starter
  • Member
  • PipPip
  • 84 posts
Hi folks,

The BIOS does indeed treat the pendrive as an internal hard drive rather than a removable drive as it doesn't show up in the removable drive list. I don't have an 'ignore other device option' sadly, apart from ignoring external drives! That of course is exactly what I want.

Regarding the cable question, the hard drive supplied with the PC is an IDE hard drive and shows as primary slave during the POST screens. Whether i could make it a primary master or soemthing i don't know - I think I'll have the case off and look at jumpers...

Irritatingly none of my other get picked up by the BIOS as 'internal' hard drives

Thanks for the help though, I'll report back if I can find anything else
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP