Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Mount/unmount prorblems with external hard drive in Ubuntu


  • Please log in to reply

#1
Roger D

Roger D

    New Member

  • Member
  • Pip
  • 2 posts
Hi

I've got a unbuntu 6.06 installation, on the whole it's just excellent. However, I've run into the following problem:

I've got a Western Digital My Book external hard drive. Up to now, it automatically appears on the desktop whenever I switch on. Suddenly it's stopped doing this.

When I click on Places>computer, I see the My Book icon complete with the Gnome footprint icon (not sure if there's any significance in the icon). When I right click on 'open', I get the message: 'Uanble to mount the selected volume'. 'Show more details' gets me:

error: directory/media/mybook not empty
error: could not execute pmount.

I know the drive is still working, as it's OK in Windows.

It looks as though I've failed to unmount the drive at some stage, but when I look in /media, this is what I get:

[email protected]:~$ cd /media
[email protected]:/media$ ls
cdrom cdrom0 hda1 My My Book
[email protected]:/media$

Which suggests My Book is indeed mounted - it's in dark blue, just like hda1. I'm a bit puzzled by the My (in black text) in front of My Book. It's a file, but what it's doing I just don't know.

I thought it might be worth trying to umount My Book, but this is what I get:

[email protected]:~$ cd /media
[email protected]:/media$ ls
cdrom cdrom0 hda1 My My Book
[email protected]:/media$ sudo umount "My Book"
umount: My Book: not mounted
[email protected]:/media$

Which, to me, is totally weird - one minute my system is saying a drive is mounted (probably); the next it's saying it isn't.

I'm not sure if it's relevant, but this is my fstab file:

/etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda3 / reiserfs notail 0 1
/dev/hda1 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda2 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

I'm pretty much a Linux beginner, but out there I'm sure there's a Linux expert for whom these message all make perfect sense. I'd love to hear from them

Regards

Roger D
  • 0

Advertisements


#2
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,645 posts
Try doing a "df" to see what is mounted, I suspect it is not mounted though.

It looks like Ubuntu does an additional check to make sure that the mount point directory is empty, which is nice in a way, but also annoying :-). Go to the directory and type "ls -A". That lists the hidden files, except "." and "..", the "-a" option would list those, but those directories are always there, so what is the point.
  • 0

#3
Roger D

Roger D

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
HI thanks for the response, but what's a "df"
  • 0

#4
Kemasa

Kemasa

    Nobody

  • Technician
  • 1,645 posts
Type "man df" at a command window:

df - report filesystem disk space usage
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP