Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

usb speakers stop my mouse from working!?


  • Please log in to reply

#1
libba

libba

    New Member

  • Member
  • Pip
  • 3 posts
Hi all

Have new pair of i-rocks usb speakers, when I switch them on my wireless mouse stops working!!!

Any ideas to fix this would be greatly appreciated!!
  • 0

Advertisements


#2
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
try moving the wireless USB receiver away from the speakers...
  • 0

#3
libba

libba

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Thx for the idea Happyrck but unfortunately didn't help!!
  • 0

#4
macten

macten

    Retired Staff

  • Retired Staff
  • 638 posts
had to delete what I wrote.....

all I can think of is to download the latest drivers and re-install.

edit...how many usb ports do you have? front and back?

edit....go into Device Manager:

start>settings>control panel>system>hardware>device manager

expand usb controllers...do you see any yellow exclamation marks?

I try and avoid using the front usb ports but in this case you may have to try installing your wireless mouse there......with the speakers installed in the back.....

edit...man....I can't spell tonight.....

Edited by macten, 11 November 2006 - 12:13 AM.

  • 0

#5
macten

macten

    Retired Staff

  • Retired Staff
  • 638 posts
OK...try this....with a music cd playing, turn off your speakers. Does the mouse work?
  • 0

#6
libba

libba

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Cheers macten........problem solved!!!

Chopped & changed my usb connections now all is well.......

Many Thanks!!! :whistling: :blink:
  • 0

#7
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts

Cheers macten........problem solved!!!

Chopped & changed my usb connections now all is well.......:) :rofl:


:whistling: :blink: :help: you did what
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP