Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

I need help finding and installing Win98 SE drivers!


  • Please log in to reply

#1
DjFonti

DjFonti

    Member

  • Member
  • PipPip
  • 98 posts
Hi all. Yesterday, with the great help of wannabe1, I managed to perform a clean install of Windows 98 SE on my PC. I downloaded the Everest program to find out what drivers I need. Firs off, I looked at system in the control panel, and went to check device manager, it had the manufacturer and brand listed by the CD and DVD-RW drives. This would suggest the drivers are already on, no? Is that possible, considering I haven't installed any?

Also, as far as I know, just my soundcard and graphics card drivers are needed, compared to the format and install I thought this would be a relatively easy task...yet despite having the names of the hardware, I can't seem to find a match (due to sketchy titling of drivers everywhere I look), less know how to install them?

The name of my soundcard is - Creative SB Live! Value (CT4830) Sound Card

and my graphics card is 3Dfx Voodoo3 Banshee AGP SGRAM. I'm on Win 98 SE. Could anyone tell me a website (other than driverguide.com) or a place where I could find the drivers for these, because they all seem to come under blanket or unspecific titles, and have no installation instuctions.

Thank you! :whistling:
  • 0

Advertisements


#2
Retired Tech

Retired Tech

    Retired Staff

  • Retired Staff
  • 20,563 posts
Is there a version number listed?

http://www.falconfly.de/banshee.htm
  • 0

#3
DjFonti

DjFonti

    Member

  • Topic Starter
  • Member
  • PipPip
  • 98 posts
Well I've managed to do the soundcard. The graphics card is proving to be the problem. That is all the info I have managed to obtain from Everest, it's an old graphics card....something like 3dfx Voodoo Banshee 16mb or something....I know, very vague. I'm trying that link....
  • 0

#4
DjFonti

DjFonti

    Member

  • Topic Starter
  • Member
  • PipPip
  • 98 posts
Cheers Keith, that link worked a treat, the graphics seem to be fine now....thanks again.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP