Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problems with drivers after reinstalling W98


  • Please log in to reply

#1
ferndoodle

ferndoodle

    Member

  • Member
  • PipPip
  • 81 posts
:tazz:
Hi,

I'm really starting to feel like a regular here with all the problems I've been having.
I have a Compaq Armada 7400 with 366MHz, 128MB ram and running Windows 98.
I formatted my hard drive and when I reinstalled Windows, it didn't recognize my modem and the settings in my display only go to 16 colors and the lowest setting
for the display. I have no idea how this happened.

I tried going to the Compaq site and I downloaded a softpaq that supposedly had the modem driver in it but that was missing a dll file which I found out when I tried to download and install it in the computer. The pcmcia modem card works fine but I really want to use the internal modem.

Do any of you know how I can solve these problems asap? I would really appreciate your help.

ferndoodle
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Well, as you seem to be aware, you've got driver problems.

How do you know it was missing a dll (modem driver)

Do they not provide a video driver? (compaq, I mean)
  • 0

#3
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
Hi Gerry,

I was able to download the driver off of the Compaq site but when I go to install it I get the message - Error Starting Program A required DLL file, MFC42U.Dll is missing.

I also went to the site and downloaded a graphics driver but nothing in my display settings has changed so I don't know if it worked.

Any suggestions?

Ferndoodle
  • 0

#4
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
http://www.winsite.c...fo?500000023982

get the dll here, then try both again

in device manager, what is the display adapter?

Recognize with that old of a laptop, you may only have 800 by 600 resolution
  • 0

#5
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
[COLOR=blue]

Hi Tex,

I replaced the file MFC42.DLL. I am still having problems installing the drivers for the modem though. I now get a popup that says Warning, "could not execute file delmodem.exe.

When I check the modem properties it shows the modem in port 1 but I get a popup error window saying "modem failed to respond. Make sure it is properly connected and turned on. Verify that the interrupt for the port is propery set" When I checked the interrupt it was set to 4. I know nothing about how to set the interrupt I'm afraid.

I am happy to say that I was able to get the drivers downloaded for my display and that is functioning properly now. All I need is to get this modem back to working and it will be back to normal. Any other suggestions?

ferndoodle
  • 0

#6
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
[COLOR=red]

:tazz:
Hi,

Just thought I'd let you know on my progress. I can connect to the modem now and it dials. I get a popup box while I am dialing that says "Error Starting Program" A required DLL file, MFC42U.DLL After the modem connects me and verifies my name and password, it disconnects and I get an error 691.

I'm so close to solving this problem I hope that you can figure out what my next step should be. I have already tried to install the MFC42U.DLL twice so I don't know why I'm still getting that error. Is there a way to check if it really did install? I'll be waiting to hear back from you.

ferndoodle
  • 0

#7
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
start > run , type

regsvr32 MFC42U.DLL
  • 0

#8
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
:tazz:
Gerry,

I did as you suggested and received this message.

Load Library ("MFC42U.DLL") failed
Get Last Error returns 0x00000485

I had previously tried to download this at the Microsoft Libraries Update site.
Obviously it didn't work. Where do I proceed from here?
  • 0

#9
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
libraries

Try downloading them from MS itself
  • 0

#10
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
:tazz:
Hi,

I have made some progress. I was finally able to download the MFC42.DLL file last night to my W/System and W/System32 files. The computer modem connected fine to my isp. This morning I started getting popups when I went to connect to the isp. The first one said: (MFC Runtime Module) cannot be loaded on W95 or W3.1 It takes advantage of Uicode features.

The next said: The MFC42U.DLL file cannot start. Check the file to determine the problem. Did I make a mistake installing them into both files? Someone said I might have downloaded the wrong MFC42U.DLL file for my system. I need to get rid of these popup messages. I am still able to connect to my isp with my internal modem.

Could you please give me some more help?

ferndoodle
  • 0

#11
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
It sounds like it...(wrong dll)

Please download the ones I linked to, which are intended for windows 98
  • 0

#12
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
:tazz:
Hi Gerry,

Well, as you can tell from my smiley, I finally was able to get my computer running right. I got a little disgusted and decided to start over by reformatting again and reinstalling W98. I had some problems with my W98 installation disk and that may have been why I was missing the MFC42U.DLL to begin with. It took me a while to get the modem drivers and then when I tried to connect to my isp I received the same message about the DLL. I went back to the site you had given me at winsite and downloaded the MFC42.DLL file to the C: system files. This time it worked perfectly. I must have downloaded the wrong file for my system the first time. Now the modem connects with my isp the way it used to.

Can a W98 disk become corrupted? Short of buying another one, what can I do?

ferndoodle
  • 0

#13
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
back when windows 98 was still supported, Microsoft would send you one if it became damaged.

Yes, CDs can...they get scratched, or slightly warped.

You can, however, easily copy anyone's CD and use it,provided it is the same version as yours. This is not piracy. You purchase a license for Windows. The CD is merely the delivery medium.

Windows CDs are not copy protected in anyway...so far
  • 0

#14
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
btw, MFC42.DLL belons in c:\windows\system....is that what you mean?
  • 0

#15
ferndoodle

ferndoodle

    Member

  • Topic Starter
  • Member
  • PipPip
  • 81 posts
:tazz:
Gerry,

Yes, that's what I meant. I think I tried putting into the system32 files before.

ferndoodle
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP