Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Pagefile


  • Please log in to reply

#1
Mike7392000

Mike7392000

    Member

  • Member
  • PipPip
  • 33 posts
Hi, I'm having a pretty strange problem with my Pagefile limit automatically being lowered.

A few days ago my laptop overheated and shut down multiple times [I did allow for a cool-off period between starting the laptop up again]. I allowed the computer to run the automatic checks it sometimes does when the laptop shuts off unexpectedly.

But a couple of days ago upon logging into my XP profile I received a pop-up informing me the virtual memory was too low and Windows had automatically created a temporary paging file for me, it gave me instructions on how to fix this so I followed these instructions.

So I set the recommended minimum [718MB] and doubled it for the limit, I restarted my laptop.
Upon logging in again I received the pop-up again, so after seeking some help elsewhere I tried disabling the pagefile completely, restarting [When restarting with no pagefile I did not receive the pop-up] and setting new limits, but I continued to receive the pop-up messages.

I've tried setting different limits [I have more than 2GB free on my C: Drive so I don't think that's the problem] but continued getting the pop-up.

Then I noticed in the Windows Task Manager that under the Commit Charge (K) [From what I can tell this is my Pagefile] limit was set to only 673,084, which is well below even the minimum size I set. Whenever the commit charge has reached the limit I've received warnings about low memory.

No matter what I do, I can't find any way of raising the limit [I've tried editing the Min/Limit in regedt32 too].

The only real effect this is having is that I can't play a game because of the lack of virtual memory, and I could probably survive without playing the game, but it's a problem I'd like to solve nonetheless.

I hope I've given enough information, thanks for any help.

Edited by Mike7392000, 04 December 2006 - 08:29 AM.

  • 0

Advertisements


#2
b1caez01

b1caez01

    Banned

  • Banned
  • PipPipPip
  • 445 posts
Check these sites:

http://www.msfn.org/...php/t61176.html
http://www.msfn.org/...php/t34135.html

Edited by b1caez01, 04 December 2006 - 09:13 AM.

  • 0

#3
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
click on my computer... then right click on C drive...then properties...tell us what you see or use the screen capture program of your choice and post it back here..
your problem sounds like you don't have very much free space so windows has to keep shrinking the swap file size...there are things we can do to get rid of useless files and settings to help...I need to know what we have to work with though..
  • 0

#4
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
b1caez01 - I tried following the sites, created a '.vbs' file, but got completely lost on the RunOnceEx.

happyrck - I think my problem could be bigger than just losing pagefile. I currently have 1.74GB out of a possible 37.2GB free. This is strange, because I only just rebooted my laptop and I know for a fact that before I rebooted I had 2.02GB free. I'm also quite confident I had more than 2.5GB free earlier in the day.

EDIT: I've just realised for all my panicking so far, I haven't even tried a system restore to a week or so ago yet. Should I give that a try and see if it fixes things?

Edited by Mike7392000, 04 December 2006 - 12:11 PM.

  • 0

#5
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
yep...but I don't think it will help...

get ccleaner and run the cleaner...the default setting are good..

http://www.filehippo...nload_ccleaner/

then left click on your C drive...then ...properties.. and UNCHECK..allow indexing ect ect....yes to subfolders...this can take several minutes to complete...if you have alot of music or video files you may want to burn them to CDs or DVDs.....go to your add remove in the control panel and delete anything you don't use...try to get as much free space as you can
  • 0

#6
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
Okay, I'd run CCleaner earlier today so it didn't have much of an effect.

I deleted a load of stuff I wasn't that desperate to keep and I'm now up to 4.88GB. Is that enough or would you like me to find a bit more stuff to remove?
  • 0

#7
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Even now, after you removed a lot of material, your hard disk barely reached the minimum space required for certain operations, most important being defragmantation, which requires a minimum of 15% of disk volume to be accomlished. When you had 2-2.5 you were way below the minimum and it is possible that windows could not allow this, especially if the volume is badly fragmented.

I would try, if possible, to free more space, run defrag and then check the virtual memory again.
  • 0

#8
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
did you turn off indexing...
  • 0

#9
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
Yeah, turned off indexing, I've now freed up 7.25GB [Of 37.2], I'll start defragmenting now?
  • 0

#10
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
yep...if your using the stock defragger...then run it in safe mode...
  • 0

Advertisements


#11
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
Okay, I defragmented, it said it couldn't defragment some parts.

I restarted my laptop, got the pop-up again [Limit is still auto-set to 670MB or so], and my free space has dropped another 700MB. Very weird. :whistling:
  • 0

#12
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
When you look in Task Manager > performance, what values do you get for Commit Charge (total, limit, peak). I assume that you allow the system to manage the size of the page file (control pannel > system > advanced > advanced > virtual memory > change > system managed size).
  • 0

#13
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
Total - 373,000 [Or there abouts]
Limit - 673,084
Peak - 380,756

And nope, I've got it set myself [Initial - 718MB [The recommended] Limit - 1536].
  • 0

#14
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Try to let the system manage itself and see if you still get the message.
  • 0

#15
Mike7392000

Mike7392000

    Member

  • Topic Starter
  • Member
  • PipPip
  • 33 posts
Nope no difference, the commit charge limit is exactly the same too.

[By the way, thanks for all the help so far people, really do appreciate it]
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP