Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

SATA RAID Controller Problems


  • Please log in to reply

#1
kaverorzi

kaverorzi

    New Member

  • Member
  • Pip
  • 7 posts
I recently purchased two WD SATA 150 Hard Drives to set up a raid. My Motherboard supports SATA 150 and the cables I have connecting the HDs are SATA150. Before I installed the hard drives the controller showed as working as normal in the device manager. When I have power going to the drives, the SATA controller fails to start and I recieve a This device cannot start. (Code 10) error in the event viewer. I followed Microsofts advice and updated the driver to no avail. I can tell when it is going to fail during the POST. I get prompted to enter the SATA RAID utility and when I enter, it cannot find any drives. During the Winows loading screen with the scrolling bar, it will hang for an unusual amount of time and then load into Windows. When no power is going to the drives, it will load normally and the controller will display as working. Booting off the Windows CD, the drivers will install properly but no disks get detected and I am forced to exit setup so it isn't recognizing the disks or the controller is failing there also. I have a feeling my problem lies within the BIOS :whistling: The only thing I saw in the BIOS that said anything about SATA was in the advanced setting where I can set the boot order and such. One of the boot options was set to like PCI SCSI and the option I could change to was SATA 8237 and I changed it to that but the symptoms remained. I do have a PCI ATA-100 RAID controller that I have a couple of IDE drives connected to, but the PC has never confused it with SCSI or anything. Never have has an issue with it either. Perhaps I need to flash my BIOS to a more recent version but I cannot seem the find a version that clearly states it is for my make and model for my MOBO, even at the manufactures site. I mainly am just looking for any ideas on what to try or what setting to consider playing with in the BIOS or just another perspective because my head hurts :blink: . Let me give you some of my hardware details:

VIA SATA RAID Controller ]

Device Properties:
Driver Description VIA SATA RAID Controller
Driver Date 7/5/2004
Driver Version 5.1.2600.410
Driver Provider VIA Technologies, Inc.
INF File oem24.inf

Device Resources:
IRQ 20
Port BC00-BC07
Port C000-C003
Port C400-C407
Port C800-C803
Port CC00-CC0F
Port D000-D0FF

Motherboard Properties:
Motherboard ID 01/04/2005-PT800-8237-6A7L2D4DC-00
Motherboard Name DFI PT880-ALF

Front Side Bus Properties:
Bus Type Intel GTL+
Bus Width 64-bit
Real Clock 133 MHz (QDR)
Effective Clock 533 MHz
Bandwidth 4267 MB/s

Memory Bus Properties:
Bus Type DDR SDRAM
Bus Width 64-bit
DRAM:FSB Ratio 1:1
Real Clock 133 MHz (DDR)
Effective Clock 267 MHz
Bandwidth 2133 MB/s

Chipset Bus Properties:
Bus Type VIA V-Link
Bus Width 8-bit
Real Clock 67 MHz (ODR)
Effective Clock 533 MHz
Bandwidth 533 MB/s

Motherboard Physical Info:
CPU Sockets/Slots 1 Socket 478
Expansion Slots 5 PCI, 1 AGP
RAM Slots 3 DDR DIMM
Integrated Devices Audio, LAN, IEEE-1394
Form Factor ATX
Motherboard Size 220 mm x 300 mm
Motherboard Chipset PT880

Motherboard Manufacturer:
Company Name DFI Corporation

BIOS Properties:
BIOS Type Award
Award BIOS Type Phoenix - AwardBIOS v6.00PG
Award BIOS Message (80LVD104) EVALUATION ROM - NOT FOR SALE
System BIOS Date 01/04/05
Video BIOS Date 05/25/04

BIOS Manufacturer:
Company Name Phoenix Technologies Ltd.
  • 0

Advertisements


#2
austin_o

austin_o

    Retired Staff

  • Retired Staff
  • 2,089 posts
Hi and welcome to Geeks to Go. I went to the DFI web page and found bios, driver and manual for your motherboard. Take a look at http://www.dfi.com.t...s...=MB&SITE=US
  • 0

#3
Coda24

Coda24

    New Member

  • Member
  • Pip
  • 1 posts
kaverorzi,

Were you able to figure out how to fix this problem? I'm running into the same exact issue. I bought a WD Caviar 250GB SATA drive and neither the RAID tool, nor Windows XP will recognize the drive.

I also get the same error message you note. If I unplug the SATA drive, no error message in the Device list. When I plug it in, I get the This device cannot start. (Code 10). So I un-install, re-boot, update the drivers (I've followed the instructions to put the drivers in a Floppy disk) but nothing.

I've updated the VIA SATA drive with the latest from the DFI web-site, read the manual about 30 times, loaded the Default BIOS checked a bunch of web-sites, but nothing has worked.

I did plug the drive into another computer I have (running on Windows 2000), and it loaded just fine, so the drive is working properly.

Anyway... let me know if you were able to find a fix, or if your drive is sitting in a dumpster somewhere.

Oopps.... forgot to say that my Motherboard is also the DFI PT880-ALF

Thanks,
Rich

Edited by Coda24, 23 February 2007 - 08:41 AM.

  • 0

#4
kaverorzi

kaverorzi

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Nope man, I was never able to fix it.

I even returned my drives and tried another manufactuer

I think those baords are just crappy
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP