Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Notebook Motherboard Onboard Component Tick


  • Please log in to reply

#1
ICDistribution

ICDistribution

    New Member

  • Member
  • Pip
  • 8 posts
I have a few notebook motherboards all from different manufacturers.. dell,toshiba, and gateway. All of these motherboards have the same problem that just randomly occured while the system was working fine.
None of them will get power properly but when i plug in an ac adapter into either one of the boards i get an internal tick coming from one of the onboard components. there is nothing mechanical plugged into the board and the sound appears to be coming from the cpu socket but i cannot verify this. Has anyone else seen this before? or come up with a solution? ill gladly replace any chip on the board...
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP