Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

computer wont turn on


  • Please log in to reply

#1
dookie270

dookie270

    Member

  • Member
  • PipPip
  • 44 posts
Alright so i've got a compact presario that i use as a secondary computer. I recently just bought a new computer and put the presario downstairs, so i had do disconnect everything and take it down there. When i hooked everything back up and turned it on, everything comes on except the actual computer. The monitor and speakers both turn on but the tower wont turn on. Theres like a little green light in the back that blinks and then the green light in the front blinks too. I've tried waiting for like an hour and then going to turn it on but it still wont. Anybody know whats going on here?
  • 0

Advertisements


#2
HPDV8315LOVER

HPDV8315LOVER

    Member

  • Member
  • PipPipPip
  • 224 posts
Probably the Power supply went out.
  • 0

#3
dookie270

dookie270

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
i dont think its that because its done this before, but it would turn on after like 15-30 minutes while the light is blinking
  • 0

#4
millerman996

millerman996

    Member

  • Member
  • PipPip
  • 73 posts
You try another power outlet?
  • 0

#5
dookie270

dookie270

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
Thats what im doing right now, but it doesnt seem to be working :whistling:
  • 0

#6
ultimateslacker2

ultimateslacker2

    Member 1K

  • Retired Staff
  • 1,581 posts
hi dookie.

Do you see any lights show up on the motherboard?
  • 0

#7
dookie270

dookie270

    Member

  • Topic Starter
  • Member
  • PipPip
  • 44 posts
No i didnt but my cousin came over who works on computers and said that it was the power supply and told me he'd replace it for me so everythings all good now :whistling:
  • 0

#8
ultimateslacker2

ultimateslacker2

    Member 1K

  • Retired Staff
  • 1,581 posts
Great!


Make sure its a Antec or Thermaltake. They are good-quality products!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP