Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

A safer way to disable User Account Control prompts


  • Please log in to reply

#1
admin

admin

    Founder Geek

  • Community Leader
  • 24,575 posts
The User Account Control in Windows Vista is one of its strongest security features, and also it's most common annoyance. Especially, it's nagging "A program needs your permission to continue" prompts. These prompts are especially plentiful when setting up and configuring a new system. We recommend you leave UAC enabled, but if you must disable it, here's a safer way. Why safer? Because disabling UAC completely also disables "protected mode" in Internet Explorer. This method removes the annoying prompts, but retains protected mode in IE.

1. Open the Local Security Policy manager by clicking Start, type secpol.msc, hit enter (or click the secpol.msc icon).
Note: An alternate path to the Local Security Policy manager is Start -> Control Panel -> Classic View -> Administrative Tools, Local Security Policy.

Posted Image

2. Navigate through Security Settings -> Local Policies -> Security Options. In the rightmost pane, scroll to the bottom and double-click “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode”, select Elevate without prompting, click OK.

Posted Image

This setting will cause a security warning at every startup, and red X shield to be visible in the task bar. To remove it, in Control Panel, go to the Security Center. On the left hand side, click the "Change the way Security Center alerts me" and choose "Don't notify me and don't display the icon (not recommended)" as shown below:

As it says, disabling security alerts is "not recommended". This is because other security notifications like the firewall being disabled or antivirus definitions out-of-date will also be disabled. We recommend it only be used temporarily, for instance when setting up or configuring a new system.

Posted Image
  • 0

Advertisements


#2
dscoo7

dscoo7

    Member

  • Member
  • PipPip
  • 11 posts
I cant find that secpol.msc file anywhere, even if I include system folders in search. And its not in the admin tools folder. any ideas???
  • 0

#3
admin

admin

    Founder Geek

  • Topic Starter
  • Community Leader
  • 24,575 posts
Which version of Vista are you running?
  • 0

#4
dscoo7

dscoo7

    Member

  • Member
  • PipPip
  • 11 posts
premium
  • 0

#5
admin

admin

    Founder Geek

  • Topic Starter
  • Community Leader
  • 24,575 posts
You've got it. Try this alternate method: Open the Control Panel, select System and Maintenance, select Administrative Tools and click the Local Security Policy.
  • 0

#6
dscoo7

dscoo7

    Member

  • Member
  • PipPip
  • 11 posts
I dont
  • 0

#7
dscoo7

dscoo7

    Member

  • Member
  • PipPip
  • 11 posts
can I post a screenshot to show you what I have for options?? If so how??
  • 0

#8
mrq201

mrq201

    Member

  • Member
  • PipPipPip
  • 252 posts
yeah i dont see it either and i am running premium
  • 0

#9
the5element

the5element

    New Member

  • Member
  • Pip
  • 2 posts
i to also have home premium and see nothing like that. just goes to prove vista is crap.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP