Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

MSI PM8M3-v (MS-7211) Not recognizing hard drive.


  • Please log in to reply

#1
Zabarang

Zabarang

    New Member

  • Member
  • Pip
  • 3 posts
If this is a repost I'm sorry. I have been looking on this site for several hours for my answer LOL.
I am going to be long winded but it is to let you all know what I have done so I don't cover the same ground again, sorry. My PC stats are in my profile, hope they are visible. Last thing, if it makes a diff the video card is not installed yet it is new also.
Ok here goes. SATA is new to me so please bear with me. I am replacing an IDE Hd that crashed beyond all hopes. My mobo is a MSI PM8M3, I bought a WD Caviar SE 160Gb SATA 300 to replace the old one. Western Digital customer service took me as far as they could. My mobo is SATA 150 so we put jumper in to make Hd compatible and used WD driver disc to format HD. It is formated to NTFS split 50/50 partitions. BIOS is set to boot Cd first then Hd. Hard disc boot priority sees my Hd "SCSI-0 : WDC WD1600JS-00MHB1". In the MSI forum I was told to set SATA enabled and keep IDE enabled, both are. I was also told to set SATA as a bootable device, I can't find that any where in the BIOS. After I said that I got no more help from them. I am connected with all new cables and my P/S is new and SATA compatible. When I go to install windows 2K Sp3 I get all the way to the point where it asks if I want to install, repair win 2K, I pick install and it gives me the message there is no hard drive to install op system. This is my problem. Any help would be greatly appreciated.
  • 0

Advertisements


#2
SRX660

SRX660

    motto - Just get-er-done

  • Technician
  • 4,345 posts
When you start installing windows within the first minute or so of the installation Windows will prompt you to press F6 to install RAID or SCSI drivers, do this. Windows will continue to install then ask you to locate the driver. now with the floppy disk created earlier in drive A: select the driver and hit Enter.

You might read this thread on it.

http://www.hothardwa...MVIEWTMP=Linear

hope it helps.

SRX660
  • 0

#3
Zabarang

Zabarang

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
I have done that and gotten the same reply I always get, the file txtsetup.oem could not be found. The floppy is good. I have tried it in this pc and also took the one out of this pc and tried it in the pc I'm working on and got the same response. I searched the driver disc, the file is there 3 times. The driver is off MSI's web site and it is for that mobo, I was very careful to get the right one. I found a post on MSI's forum that said with this mobo this happens some times just to keep trying. After 30 tries I don't think it is going to work "I know the 31st would be the one that worked LOL". I went to the link on the previous post and followed directions there and found a lot of what I have already done. I have never had a problem stump me like this, I am getting close to BFH mode LOL. I have a question about bios. In IDE primary master setting in standard cmos features what is hard disc S.M.A.R.T and should it stay disabled?
  • 0

#4
SRX660

SRX660

    motto - Just get-er-done

  • Technician
  • 4,345 posts
Here is a forum thread i saved when i had problems with SATA on my gigabyte GA 81945GMF motherboard. Maybe it can help you. It does talk about the txtsetup.oem problem.

-----------------------------------------

How to install SATA on a Gigabyte GA-8KNXP

HOW TO INSTALL SATA as BOOT DISK
http://www.pro-netwo...pic.php?t=34500

SECTION 1

Download latest SATA “Sil drivers”
http://www.giga-byte...r_GA-8KNXP (Rev

%202.0).htm [Silicon Image 3112] from Gigabyte

http://www.giga-byte...ee/Tree_128.htm (SATA Sil drivers are the

same for rev 1&2 boards) and unzip to floppy.
edited 12-17-04
The zipped driver file has now grown to more than what will fit on a floppy. So

after downloading this file, extract it to your desktop to a folder named SATA

{or whatever you want to name it} You will now see 2 folders in the SATA

folder, Si3112(non-raid) & Si3112r(RAID). You will only need to copy the

contents in the folder that contain the driver set that is needed for your

setup onto the root of the floppy disk.
BTW:the configuration ini file, "TxtSetup.oem" is needed during setup. If it

doesn't locate it automatically, it is located one level deeper in either

sub-folder "Si3112 or Si3112r" on floppy

You will also find the latest BIOS here

http://www.giga-byte...GA-8KNXP (Rev 2

.0).htm. Check which ver you have by pressing DEL when booting, when in

BIOS, press F9 to see info about your BIOS.

For the record: Drives connected to the SATA0_SB or SATA1_SB will use Intel

drivers [ICH5R] Windows will find them on WinXP CD at setup.

Drives connected to the SATA0_Sil or SATA1_Sil will use the Silicon drivers on

the MOBO CD (best to get latest from Gigabyte Site and unzip to floppy)

If planning on using 1 or more SATA drives, it is best to have master boot

drive on the SATA0_Sil connector (have Sil drivers ready on a floppy). Set it

up alone and install of OS. I recommend you only introduce the other drives

after you have BOOT disk running successfully.
1) boot system, press delete to go into bios setting
2) first select load fail-safe defaults
3) select load optimized defaults
4) go to integrated peripherals
5) set on board H/W serial SATA: enable
6) SATA function set to: BASE
7) press ESC to go back to main menu
8) go to advance bios features
9) change boot sequence: 1st: CDROM, 2nd: hard disk. Insert windows CD in CDROM

to prepare for WINDOWS installation
Press F10 save setup and exit
Shut power off.
10) connect 1 drive on Sata0_SIL controller
11) when system boots, watch for message "press any key boot from CD rom" press

enter key. Windows setup screen comes up, on the bottom will show a message

“press F6 key if special driver need to install” at this point press F6 key
12) after windows loads basic drivers, a message will show “press S key to

specify special driver” press S key and inset the floppy disk that has the

unzipped SATA Sil driver when prompted
13) press enter, system will load the Sil drivers and continued windows

installation
14) follow the messages on the display to finish windows installation

SECTION 2

To add more drives, SATA & IDE, boot up into BIOS
1) go to integrated peripherals, set onchip SATA to: AUTO,
2) on board H/W GIGARAID to: enable,(enables IDE3&4)
3) set Gigaraid function to: ATA
4) press F10 to save and exit setup
5) let system boot to windows and allow to install "Intel SATA" driver and ITE

Gigaraid" drivers
6) go to device manager and verify that the drivers loaded, now Shut down and

connect drives.

Connect remaining SATA drives first to SATA1_Sil, then to SATA0_SB and/or

SATA1_SB connectors.


Connect any IDE drives to the IDE connectors starting at IDE1 and IDE2 working

around any CD/DVD drives connected, going to "IDE3 and IDE4 Gigaraid

controller" if needed(setting master/slave jumpers on IDE drives as needed)

Once this is done, boot up

7) at reboot, watch the onscreen POST, SATA POST should find all SATA drives

and Gigaraid/ATA should find all IED drives
8) give windows time to locate and install new drives
9) reboot if necessary
10) open my computer, check if all drives show, if any drives do not show it

could be that A)they are not partitioned and formatted or B)not active
11) if BIOS recognized drives at boot POST and they do not show in My Computer,

right click on my computer icon click on manage then click on disk management

check if all drives show there, if any are grayed out, right click on each grey

drive, make it active, partition and format them as NTFS. After doing this, all

drives should show in My Computer.

Doesn't boot from my SATA drive since adding additional drives... furious

IF After adding drives, your system may no longer boot from the Sil SATA

drive,(or your drive of choice) For some strange reason, the BIOS will change

the boot order. So simply check the setting in BIOS under Advance BIOS

Features, in hard disk boot priority, make sure to set Sil SATA (or your drive

of choice) as #1 to force it to be boot drive

SECTION 3

FOR SYSTEMS WITH 2 IDE’s ONLY(no SATA)
1) load fail-safe defaults
2) load optimized defaults
3) go to integrated peripherals
4) disable on board H/W Serial SATA and on board H/W Gigaraid
5) go to advance bios features
6) set first boot device to CD rom
7) put Win CD in CD tray
8) F10 save and exit & Shut down
9) connect Drives to IDE1 and/or IED2(master/slave as needed) drivers for IDE1

and 2 will be loaded from Win CD during setup

SECTION 4

FOR SYSTEMS WITH MORE THAN 2 IDE’s ONLY(no SATA)
1) follow above to step # 4
2) disable Serial SATA
3) set on board H/W GIGARAID to: enable,(enables IDE3&4)
4) set GIGARAID Function to: ATA
5) continue with step #5
---------------------------------------

jonathanfcpotter .... i'm a complete novice and have tried and failed to

install a sata drive (hitachi deskstar 160 gb) onto my gigabyte ga-k8vnxp but i

fell at the first hurdle of what seems to be the answer from FROG i have tried

to copy the sata sil driver onto floppy but the size being 1.63 mb will not fit

onto my 1.44mb disk i've looked for a larger disk but no luck. any advice would

be a god send. and hopfully this will help others too.


Hey jonathan, download the 1.63mb zipped file, extract it to your desktop in a

folder named SATA, then look in the SATA folder you'll see 2 folders:
1) Si3112
2) Si3112r
The first is for non-raid second is for raid. So you only need to copy the one

folder specific to your setup to your floppy which is about 795kb each.

The "TxtSetup.oem" file is actually buried one level deeper in the sub-folder

which is also named Si32112.
------------------------------------

i also studied the gigabyte site today and noticed that me and frog are working

off diffrent mobos his is a GA-8KNXP while mine is a GA-K8VNXP so i looked for

the sata driver for this board but with no luck, as i go to search link after

putting all my info in such as socket 754 Via k8t800 chip set and the board

model it goes no where, is the site faulty or is it me (most probally) oops


the site for your board is here...
http://www.giga-byte...r_GA-K8VNXP.htm

Guess that's why we don't have the same options... saywhat I went to GigaByte

Site to check out the link as you did. You are right, it doesn't work

correctly. But I was able to get the link directly to the download for the

SATA-RAID for your board GA-K8VNXP

http://america.giga-...raid_via_8237.e

xe The link will start the download immediately. The file mane is

"driver_raid_via_8237.exe " It is about 5.8mb I don't know what all to do with

it since I have not and will not anino be using it in my system. I hope this

gets you going in the right direction.
--------------------------------------

well i finally got the K8VNXP mobo working with the sata hdd the answer was in

front of me all the time whistle the disk that is supplied with the mobo works

if u use it through my computer and right click to open the link. then go to

bootdvr, menu and with a floppy in the drive click C to set up a single sata

drive.
------------------------------
Well I finally figured it out. If anyone has similar problems this is how you

fix it. Go to the BIOS, disable the boot device; the second boot device (or

whatever one that is not your floppy and not your CDROM), then go and set the

SCSI boot order.
------------------------------

Theres also this.

http://www.geekstogo...rkl-t49702.html

Edited by SRX660, 31 January 2007 - 06:54 AM.

  • 0

#5
Zabarang

Zabarang

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
I would like to thank you for your help. I never was able to get the operating system installed by any of these ways so I borrowed an old Hd and formatted it after all was done I copied it to the new Hd. Now All I have to deal with is a sound prob "lack of" and on bootup it is showing 2 op systems. LOL. Can't have good without earning it. Again thank you for your help.
  • 0

#6
CitadelSystems

CitadelSystems

    New Member

  • Member
  • Pip
  • 1 posts
Dealing with this pain in the rear right now. Single drive on the RAID. Make sure on MSI's site that you choose the correct OS. For XP it has a floppy driver, while for vista it doesn't. Only a RAID driver which gives the txtsetup.oem error.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP