Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

"Safely remove hardware" icon missing in systr from time to


  • Please log in to reply

#1
JimB007

JimB007

    Member

  • Member
  • PipPip
  • 96 posts
The well known bug in XP of the missing icons i/t systray (in which case you can't access the programs unless you do a Ctrl+Alt+Delete and a forced shutdown o/t program and consequently restart the program hoping its icon reappears), has struck again: this time after a reboot or whenever it feels like the safely remove hardware icon is missing. This icon however I can't get back that easily. Anyone an idea how to get that icon back or make a shortcut ?

Before anyone redirects me to the "Kelly's corner" website: nothing there that works for me regarding the systray missing icons, neither the special freeware "Taskbar repair" tool that I downloaded once.

Edited by JimB007, 07 February 2007 - 08:19 AM.

  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
I agree it's a bug for which fixes are both varied and not always successful, and as you probably know there's no official fix either so I guess even Microsoft is baffled by this one! Read the following pages and I hope one them reveals a fix that works for you.

I can't recommend one that's worked for me because, as yet, I haven't had that problem (says he as he touches wood!!).


http://www.tech-pro.net/howto_013.html

http://winhlp.com/WxSystray.htm

http://www.mydigital...-in-windows-xp/

Edited by pip22, 07 February 2007 - 09:00 AM.

  • 0

#3
1101doc

1101doc

    Trusted Tech

  • Retired Staff
  • 909 posts
Systray icons go missing all the time. This and volume are the most common. I made a shortcut and put it in my quicklaunch. Better dialog box than the Systray icon also. Right click desktop> New Shortcut, and paste into the dialog box window for location: %windir%\system32\RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll
The normal systray icon will likely come back some day, and often does so after a log off/log on without reboot. Disabling Universal Plug and Play Service seems to help also.
  • 0

#4
JimB007

JimB007

    Member

  • Topic Starter
  • Member
  • PipPip
  • 96 posts
Thanks pip and doc I will get to the websites and check that out. Also the shortcut option for safely remove worked. I'll put it among the shortcuts on the left. Thanks.
This "disabling Universal Plug and Play Service" hasn't worked for me so far. And yes the icons come back but sometimes only after 2 restarts. And that's at leats 10 minutes waist of time in my case

Edited by JimB007, 08 February 2007 - 06:00 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP