Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

CD/DVD drive not working


  • Please log in to reply

#1
Michael D

Michael D

    New Member

  • Member
  • Pip
  • 7 posts
Heres my story:
I wanted a new computer, but to save money i reused my hard drive and cd/dvd drives from my old one becuase they were still good. So i assembled my system yesterday and got it all working but their is one problem. One of my cd drives isn't being recognized by my computer, while the other one is. When i look in bios, my working cd drive is third on the list and is called the "secondary master" or something, and my hard drive is somewere on the bottom of this list (the top of the list is a floppy drive, which doesn't physically exist...). My cd drive that doesn't work doesn't even show up. I know this drive is getting power, becuase its light turns on and i can open and shut it, but nothing happens when i put a cd in. If i go to my computer I cab see my C: drivce, my D: drive (the good cd drive), and the A: drive. the A drive is another issue, my computer thinks it has a floppy drive but i dont actually have one. so maybe its getting mixed up?

So basically, my computer isn't recognizing my cd drive, but it is recognizing a non existant 5 1/4" floppy drive that isn't there... These cd drives worked just fine in my old computer, so i doubt that they are broken.

Any help would be great
with thankfullness
Michael
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Welcome to G2G

Re. the floppy drive - don't worry about that right now. Basically the bios just assumes you have a floppy drive installed by default (although this should be a 3.5in floppy, not 5.25in!). There should be an option somewhere in the bios to disable it though.

As for the other drives...In the bios you should see the following listed :
PRIMARY MASTER
PRIMARY SLAVE
SECONDARY MASTER
SECONDARY SLAVE

You've already said that one of the optical drives is configured as secondary master, which is fine.
Your hard drive should be on a separate cable to the optical drives & should be showing up as the PRIMARY MASTER in the bios. Let me know if it isn't the primary master.

Your second optical drive should be attached to the same cable as the working optical drive. Check the jumper on the rear of this second optical drive & make sure it is jumpered in the slave (S or SL) position. If it is jumpered as Cable Select (CS) then this is also fine provided that the other optical drive is also set to CS.

Check the above things & let me know what you find.
  • 0

#3
Michael D

Michael D

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Thanks Samm, that did it!

I pooped my drive out and set it to 'slave' and it worked as soon as i restarted the computer!
my optical drives are on the same cable, and the hard drive is seperate (sata). although my hardrive is last on the list as "sata 4" should it be on sata 1? or does it matter?
  • 0

#4
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi Michael

Glad to hear both optical drives are now working.

Sorry, I just assumed the hard drive was IDE, not sata, so the primary master thing isn't relevant. As for the SATA position, it doesn't matter which SATA port the boot drive is on, especially when there's only one sata drive, so should be fine to leave it on port 4.
NB If you were to add another sata drive later on (to sata port 1 for example), then you may need to check in the bios that the boot proirity is correctly set in the bios. i.e so that the sata drive containing the Windows installation appears higher up the list than the non-bootable hard drive.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP