Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Video Card Issues


  • Please log in to reply

#1
Situationeer

Situationeer

    Member

  • Member
  • PipPip
  • 49 posts
I am having problems with my Radaeon 9600 series. I am running Windows XP Home.

I believe it is my out-dated drivers that is causing an issue with Counter-Strike. What happens is my FPS drops to like 4-15 after about 15 min of playing, this lasts for about 30 sec, then it goes back to normal. This gets progressivly worse after the first time, until it happens basically every round.

I un-installed my old drivers, and I downloaded the up to date drivers. I then installed them and what was supposed to happen is I restart the computer, upon start up it tests the new drivers and then runs them. But it never ran them nor did I see them being tested. When I look at my driver info it has drivers that are from a year ago.

A wierd issue that I am having which might be part of this problem occurs when I right click the desktop. What happens is first I get a message that says Windows installer at the top and "Preparing to install" in the middle. Nothing happens however so I click cancel. The a window pops up that says "The InstallScript engine on this machine is older than the version required to run this setup. If available, please install the latest version of ISScript.msi, or contact your wupport personnel for further assistance." At the top of this box it says "ATI Catalyst Control Center." I have tried what is stated here,http://consumer.installshield.com/kb.asp?id=Q108158 to fix it but it doesn't work.

I would greatly appreciate any help you guys could provide.
  • 0

Advertisements


#2
bmwboy

bmwboy

    Member

  • Member
  • PipPipPip
  • 152 posts
Alright, first uninstall all ATi stuff from the add/remove programs. Then, download and install Driver Cleaner Pro then run it and select everything ATi (check the box "Multiple Cleaning Filters"), the reboot, redownload the latest drivers from ATi. Then install, reboot. And check dxdiag.
Post any problems back here.
  • 0

#3
Situationeer

Situationeer

    Member

  • Topic Starter
  • Member
  • PipPip
  • 49 posts
I get the windows installer error when I try to un-install the ATI Catalyst Control Center (Which I cannot access).


I get an error when trying to install the driver after deleting the old ones that says "Setup was unable to complete the installation. Try to setup your display adpator with a standard VGA driver before running setup."

What is dxdiag btw?
  • 0

#4
bmwboy

bmwboy

    Member

  • Member
  • PipPipPip
  • 152 posts
Start-Run-dxdiag
What does it say for "main driver" under the "Display" tab?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP